System Restore Doesn't Work After Last Critical Update

  RegScriv 09:04 18 Aug 14
Locked

Microsoft's last critical update seems to have caused a number of problems, one of which is that my System Restore now doesn't work. I tried to restore after the update caused problems with connecting my Nexus 7, but none of the available restores worked. The dialogue box stated that maybe I have a disc error, but scandisc found nothing. Can anyone help.

  Batch 09:07 18 Aug 14

I know this does't help you immediate problem, but the lack of reliability of System Restore is one of the reasons I make frequent complete images of my system partition (which is just OS and pgms). I feel much more secure with complete images (not incrementals) and I have always turned off System Restore and used the images instead whenever I need to roll back.

  RegScriv 09:52 18 Aug 14

I agree and take frequent images of just the OS&prms - C drive just as you do. I'm using Macrium Reflect which I switched to when upgrading to Windows 8.1 (Acronis was reputed not to work with W8.1) and it looks like I'll have to use restore using it now. Problem is if this latest Windows update installs and causes the same problem again. I don't want to switch off Automatic Updates.

  Mr Mistoffelees 11:30 18 Aug 14

You might want to do as I do and set Windows Update to inform when there are updates but, not automatically download and install. You will then have control of what updates install but, not miss any you need.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

Where HTML5 is headed next

MacBook Pro v Surface Pro 5