svchost.exe

  alfredgerald 11:46 12 Dec 13
Locked
Answered

My PC is running very slow. Have checked Task Manager and a process called svchost.exe is using 98% of the CPU. I have also notices that there are several other files names svchost.exe on the system. Have tried restore but still happening. What’s happening?

  Jollyjohn 11:59 12 Dec 13

Are you using WWindows XP? If so it is an update that is causing it to run slow. Try turning Automatic updates" off, reboot and see if that helps.

If not it takes about an hour for the latest 4 updates to install but is fine once installed and rebooted.

  alfredgerald 12:31 12 Dec 13

I’m still running Windows XP what’s the equivalent of Services? I’ve already got Automatic Windows updates turned off, just Notify is running.

  Peter 16:05 12 Dec 13

alfredgerald,

Like Jollyjohn & Jock1e have indicated the problem is with Windows Update. Even though you have it set to just tell you an update is available the problem still occurs with Windows Update checking in the background.

I had this problem last month and Jollyjohn (I think) advised to turn Windows Update off completely. This I did and the problem is solved, but Microsoft/Windows does not give up easily and keeps trying to switch Windows Update back on. It does this regularly, two or three times a day, but I run WinPatrol and it warns me of the change to the Windows Update setting and lets me stop the change.

Try turning off the Windows Update completely and keep an eye on the setting, that should help cure your problem.

Peter.

  Batch 18:16 12 Dec 13
Answer

Step by Step Instructions:-

Go to Control Panel, Security Center.

Under Manage Security Settings (towards bottom of window), click Automatic Updates.

A new dialogue box opens. This has four options:

  • Automatic (download and install automatically) = the default

  • Download updates but let me choose when to install

  • Notify, but don't download or install

  • Turn off (so you only get updates if you manually go and check)

You should have the last one selected to avoid the performance issue.

Then (to prevent a nag popping up about Automatic Updates being disabled), back in the main Security Center screen, on the left hand side, select "Change the way Security Center alerts me" and (in the dialogue box that opens) disable the Automatic Updates alert setting.

Lastly, once a month, late in the day on the second Tuesday of the month, or very soon thereafter, one should manually check for updates. This is accessible from the Security Center screen referred to above (in the panel on the left of the screen). If you have a standard installation it should also be on your Start Menu - click the Start Menu button and look at the entries towards the top of the pop-up - one of them should be Windows Update.

You should be aware that when you manually run Windows Update AND there are updates to install it will take a very long time to run, so you should only do this at a time that is convenient to you.

  Peter 01:32 13 Dec 13

Batch,

Thanks for the very clear instructions breakdown. I've done all that, but Microsoft/Windows still insists on want to, and trying to, change the Security Centre settings back to letting me know that an update is available, even though I instructed it not to! This is the case on two separate Windows XP computers.

I think Microsoft thinks it knows best, or perhaps it would just prefer me to stop using Windows XP and move up to Windows 8.1. Paranoid moi? Of course not!

Peter.

  Batch 08:50 13 Dec 13

"or perhaps it would just prefer me to stop using Windows XP"

Yes - I think that is the conclusion that many have come to. MS maliciously impairing XP so as to drive people to later OSs?

  alfredgerald 10:06 13 Dec 13

Thanks Batch. It worked. Still getting Security alert but I can live with that.

  woodchip 10:47 13 Dec 13

You need to set updates in Control Panel to off not Notify. You can still update by Manual means going to start Windows Update then run Custom Updates

  Batch 11:35 13 Dec 13

If you've followed he instructions I've posted.....

"Then (to prevent a nag popping up about Automatic Updates being disabled), back in the main Security Center screen, on the left hand side, select "Change the way Security Center alerts me" and (in the dialogue box that opens) disable the Automatic Updates alert setting."

......you shouldn't really be getting the Security Alert.. Most strange.

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now