A suitable sound card for my PC?

  CurlyWhirly 13:02 10 Sep 05
Locked

Can anyone please recommend a sound card for me?
I would love to ditch onboard sound as it's a bit cr*p!


I have tried Creative soundcards before they do not work correctly due to a problem known as 'PCI latency'.


I have been to click here


and tried the 2 following solutions but neither of them worked.


"Patch for Creative Labs SoundBlaster Live! and Audigy-series drivers - This patch will disable the "turbo mode" feature of newer Creative drivers, which will solve "crackling" or distortion problems for some users. Try this patch if the VIA "PCI Latency" patch does not solve your sound-related problem."


"PCI Latency patch for VIA chipsets - This is a Windows driver that will patch motherboards that have VIA chipsets. It is intended to solve many problems, including: Sounds played by a Creative Labs sound card are distorted"


I have been advised to get an M Audio sound card but does anyone have a ViA chipset (like me) and has experienced crackling noises with Creative sound cards?


If so which sound card would you recommend that *is* compatible with my motherboard which is a Gigabyte GA-7VAXP?


Cheers.

  CurlyWhirly 13:04 10 Sep 05

p.s. I have tried both the Sound Blaster live! and Audigy 1 sound cards and even though the sound was excellent I couldn't put up with the crackling noise all the time so I ditched them.

  Methedrine 13:07 10 Sep 05

I have an Audigy 2 sound card in my system and have had no problems whatsoever. I have had other sound cards at different times but have always gone back to Creative.

click here

  CurlyWhirly 13:15 10 Sep 05

Mmm... I know that the Audigy 2 soundcard is going to be better than the Audigy 1 (which I once had) but I don't really want to shell out for it and then find out that I still get clicking noises as according to the website that I looked at it is a problem with Soundblaster Live! *and* Audigy soundcards.


I found it most annoying while online as every time I clicked on a website link I would hear a click coming from the speakers.


I don't know if Audigy 2 would be the same though as it was nearly 2 years ago when I last tried Audigy 1 so perhaps this problem has now been resolved?


Perhaps I would be better posting on the Creative support website instead of here - I should have thought of that before!

  Chegs ® 14:12 10 Sep 05

You have got me confused mate.I have the(almost)exactly same mobo(mines the Ultra)and I have a SB Live 5.1 card.It works flawlessly.

I know that Via chipsets can cause problems with SB cards(my Epox mobo used to emit a loud squeal as soon as a sound was emitted thru the speakers,then crash completely)I tried several patches,but nowt cured it,so my daughters PC gained the SB until I bought this Gigabyte board.

Are you disabling the game port in BIOS,try disabling ALL unused ports in BIOS(LPT/Parallel,etc)then once you have the SB installed,disabling its game port too.(Device Mngr)click here

  CurlyWhirly 14:17 10 Sep 05

Thanks for your reply.
In fact it was a recent PCA thread of yours where you mentioned clicking noises that prompted me to post this!


I don't have either of the soundblaster cards now as I sold them but I *didn't* try disabling the game port like you mentioned so perhaps that *could* have been the problem?


The game port is something to do with one of the connectors on the sound card I take it? (confused)

  CurlyWhirly 14:20 10 Sep 05

p.s. the reason why I was a bit confused with your game port answer was because I usually use another USB socket for my joystick when playing PC games NOT the connector on the sound card itself so why would I need to disable it?

  CurlyWhirly 14:21 10 Sep 05

p.p.s I *no* longer have a sound card so what I meant to say above was when I *used* to have one.
I'm now using onboard sound chip.

  Chegs ® 14:21 10 Sep 05

It is the "joystick" port on the SB,I never use either the SB cards,or the mobo ports "joystick" ports.I have a nifty USB gamepad,that I much prefer to use.

  Chegs ® 14:24 10 Sep 05

The reason I suggest disabling ALL unused ports,is to reduce any chances of an IRQ conflict by freeing up as many as possible.

  CurlyWhirly 14:27 10 Sep 05

So even though I wasn't using the game port just having it enabled in the BIOS could have caused a possible IRQ conflict?



That's something I will look at when I buy one which should be tomorrow now - PCW.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…