Sudden loss of all USB ports

  ex-wirecutter 11:51 22 Mar 11
Locked

My Widows XP system has lost access to all USB ports
I have tried reinstalling drivers but get error signal saying they are missing or corrupted. My USB keyboard works fine on the setup screen but when XP starts nothing . I am having to use Linux OS to type this. Have searched Microsoft for replacement drivers but can't seem to find any. Cant use printer or USB pocket flash drives in XP , but all work fine on Linux so must be an XP fault. Am a bit dubious about using these sites that offer to " update all drivers " for free , anyone had any experience of these ?

  Nontek 12:28 22 Mar 11

You should not need to manually update the drivers. Simply uninstall ALL USB Ports, then re-start PC. All Ports should then work as normal.

  Jollyjohn 12:32 22 Mar 11

What happens if you unplug all your usb devices and boot into windows and then plug them in one at a time?

I appreciate you have a usb keyboard and probably mouse as well but could you borrow an old ps2 mouse and when in Windows go to control panel - hardware - device manager and delete / uninstall usb controller - reboot into Windows and it should find usb controller and re install the drivers.

  ex-wirecutter 13:03 22 Mar 11

Thanks for the suggestions but when I uninstall the drivers and then reboot , XP finds the USB ports but then just reinstalls the corrupt drivers . In hardware manager they are shown with an exclamation marks.

  Nontek 13:29 22 Mar 11

If you have your original XP Disc you could run sfc/scannow ..... during the scan you will be asked to insert the XP Disc.

  Jollyjohn 13:43 22 Mar 11

Do you have a driver cd for your motherboard? There will be a usb driver on this.
Alternatively go to your motherboard or PC manufacturers website and search for the usb drivers

  ex-wirecutter 13:53 22 Mar 11

Once again many thanks for the suggestions , I will search for my original XP installation discs ,(which I haven't seen for a while )and give both ideas a try. Have to go out shortly so may leave it till tomorrow. Thanks again.

  ex-wirecutter 15:40 22 Mar 11

Have spent quite some time uninstalling and trying to reinstall usb drivers from various sources , but XP stubbornly insists that the best drivers are installed but they don't actually work. Someone suggested I buy a powered hub with it's own driver , but if none of my usb ports are working how's that going to help ? Fortunately I only use XP for devices that I can't get Linux drivers for so I'm not stuck , but just as a project I'd like to keep plugging away at this problem as I don't like things that don't work , there must be a solution.

  woodchip 16:13 22 Mar 11

You have not said, if you tried SFC /SCANNOW from Run Box. as above you need a XP CD not a Restore CD for the above

  woodchip 16:14 22 Mar 11

note the space before the / forward slash

  ex-wirecutter 10:49 23 Mar 11

Thanks woodchip , I must admit I didn't see the space before the forward slash which would probably account for why it didn't work when I tried it .

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now