Strange Mouse Problem

  RobCharles1981 09:57 08 Nov 07
Locked

Morning Chaps Hope everyone is well.

I have a Logitech G5 Laser 2007 Mouse and yesterday its been playing up on me, Windows is finding the mouse but an error occurred when installed the mouse, I tried re-installing the setpoint software no change, but yesterday now the courser wouldn't move on the screen! Arrragh!!

I tried doing a Repair Install the mouse came back to life but it had other ideas.

What should I do next?

  howard64 10:52 08 Nov 07

1. visit the web site of the maker and see if it has an updated driver. 2. disconnect that mouse and uninstall any software previously installed for it. Reboot and follow the makers installation instructions.

  RobCharles1981 11:01 08 Nov 07

click here=

I downloaded the latest setpoint software but I'm unable on that site to locate a driver for the mouse.

  howard64 11:07 08 Nov 07

amongst the products on their site do they not list your mouse? If they do software is normally available.

  howard64 11:11 08 Nov 07

click here that page for your mouse has a download button on it.

  RobCharles1981 11:40 08 Nov 07

Thats the software I tried Windows is not seeing the mouse properly.

  Chris the Ancient 12:05 08 Nov 07

Is it worth doing a system restore to a time when you know the system was working OK? Then, if necessary, reinstall the mouse.

  RobCharles1981 12:14 08 Nov 07

Hi Chris
I turned off System Restore!
R

  howard64 12:21 08 Nov 07

is it perhaps a usb mouse? is usb mouse enabled in your bios?

  RobCharles1981 12:22 08 Nov 07

Its a USB Mouse usb is enabled in the Bios.

  RobCharles1981 18:09 08 Nov 07

Strange this

I tested this mouse on my Spare Computer and it picks up fine. When I plug it back in on my main rig it doesn't pick up, I'm using a spare mouse right now.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac