Still no SATA

  sorceror7374 16:51 22 Jan 06

I've got the drivers all installed for the SATA drives in windows xp but they are listed in the device manager as 'unreadable'. When I tried to install the drivers while booting up with the XP CD I got and error message stating 'File \WinXP\fasttx2k.sys caused an unexpected error (18) at line 2108 in d:\xpsp1\base\boot\setup\oemdisk.c.
Any suggestions on how to get SATA working?

  Zeppelyn 17:10 22 Jan 06

What make/model are they ?

Are they attached via Motherboard or PCI Controller, im guessing but that fastx2k.sys looks like a Promise Driver.

  sorceror7374 17:32 22 Jan 06

They are Promise drivers indeed. They're all part of my Chaintech separate controller needed.

  Fruit Bat /\0/\ 19:35 22 Jan 06

Suggest you update the drivers look on the Chaintech site for the latest drivers fo your board. click here

  sorceror7374 21:19 22 Jan 06

Unfortunately the latest drivers are what I've already installed.

  phil46 21:23 22 Jan 06

Have you set raid up F6 when installing the WXP.

  Joe R 21:37 22 Jan 06


just noticed this thread, and i,ve posted a link for you in your original thread.

Hope it helps,
Regards Joe.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…