Still can't get rid of startup error message

  lecram 09:01 07 Jun 07
Locked

“C:\Windows\_DEFAU~1.PIF Invalid program file name, please check your pif file. Choose close to terminate the application”

Can anyone help with this please. I have taken a lot of peoples suggestions in running different registry cleaners, performing an sfc scannow operation but I cannot get rid of this startup message. Any suggestions??

  johndrew 09:30 07 Jun 07

Don`t know if you have seen this, but it may help click here

This may also provide a bit more info click here

  wee eddie 10:39 07 Jun 07

Please give us a link to the original thread so that we are not duplicating suggestions.

It would also be useful to know what Microsoft Programs that you have installed and any that you have deleted in the couple of months prior to the arrival of this Error Message.

All deletions in that period, not just the Microsoft ones.

  rodriguez 10:51 07 Jun 07

Go to Start, Run and type in regedit and press Enter. The will start the Registry Editor. In the registry, go to HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\Windows\CurrentVersion\Run. Here you should see a list of programs that start with Windows. Have a look to see if there's anything to do with the PIF file that's trying to start up (or any other thing that might be related to it) and delete them. If there isn't anything, go to Edit, Find and search for _DEFAU~1.PIF. If this brings up the entry, delete it.

Another thing you could try is to go to Start, Run and type in msconfig and look in the Startup tab to see if there's anything in there to do with it and if there is, disable it.

If nothing is there, then go to My Computer, then C:\ then Windows. Find the _DEFAU~1.PIF file and open it with Notepad. See what file it points to (PIF files are MS DOS shortcuts anyway) and go through the previous steps to remove it from startup.

  rodriguez 10:54 07 Jun 07

One thing I should have mentioned - the file might not be called _DEFAU~1.PIF - ~1 appears on the end when it's been shortened to 8 characters, so do all the searching for _DEFAU. This will make sure it finds the file that starts with the right name.

  lecram 09:14 08 Jun 07

Hi Rodriguez

When I run the regedit option you mention I do find what is called a (Default) entry and under the Data option it says (value not set) whereas all of the other files have specific file extensions. Should I delete this? Could it be the defau~1.pif problem I an having at startup?

Lecram

  rodriguez 12:38 10 Jun 07

You should leave that one, it's supposed to be there. Try the second method of going to My Computer, then C:\ then Windows. Find the _DEFAU~1.PIF file and open it with Notepad and see what it says. Remember it might be called default and then some numbers, as files with ~1 on the end have been shortened for DOS.

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Fresh New Fonts of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced