SSD and Windows XP SP2

  Ian in Northampton 04 Jun 12
Locked

I'm about to take the plunge and buy the Intel 330 SSD. It seems well reviewed, and it's a price I want to pay (less than £70 for the 60GB version, which is more than enough for my OS and programs). I'll be installing it on an XP SP2 system (I have my reasons for not wanting to install SP3). Does anyone have any experience, ideally with this drive or alternatively with any other SSD, with XP, and, ideally, XP SP2? Everything I've read says that, while Windows 7 is the idea OS for an SSD, the Intel utilities provided mean that it should work well with XP (if not as well as with W7).

Any thoughts/experiences would be gratefully received.

  KRONOS the First 05 Jun 12

I have been using SSD's for a while now and like you thought that 60GB would be plenty but I was wrong,in fact because you can get some great deals on 128GB SSD's I would recommend that size rather than 60GB. I might add I have only used SSD's with Windows 7 so have no experience of XP, but reading quite a bit from here I am not sure that I would use an SSD with XP. SSD + XP.

You will need Sata drivers slipstreamed in to your XP installation disk.

Info.

  KRONOS the First 05 Jun 12

Sorry info link is in the wrong place. This is the link for slipsteaming Sata drivers into XP.Slipstream.

Thanks Chronus. Hmmm - food for thought. £70 for a 60GB, £84 for a 120GB. The difference isn't great, I guess. The reason I'm focusing on the Intel drive is the provision of the toolkit which is supposed to make setting up and maintaining the drive easier under XP, given the lack of native support for SSD under XP.

The other issue implicit in what you say is that it won't just be the £84 - from the article you pointed me at, it looks as if I ought to spend some money on memory - either 2GB or 1GB, depending on which system I decide to upgrade.

Also interesting re the SATA drivers. In my thread here I was getting to grips with a newly-acquired machine, and ended up slipstreaming SATA drivers into my XP disk. That all went fine. But, weirdly, I also have a Dell that I dual-booted - and I just used my regular XP SP1 disk to do that, with no SATA drivers slipstreamed - yet the Dell has SATA drives. How could that have been possible?

  rdave13 05 Jun 12

The Dell you dual booted without the SATA drivers must have been set to IDE. For an SSD to work efficiently the bios must be set to AHCI and you will need the sata drivers slipstreamed in your disc. Have a look enter link description here

Also in XP you will need to align your partitions, link

Thanks rdave (and Chronus again). I'm starting to suspect this may not be a good idea. The extra performance would be great to have, but it seems there's a lot to think about - and they seem to take a lot of looking after if they're to continue to perform well.

Advertisement

This thread is now locked and can not be replied to.

How to watch Wimbledon 2015 live online: follow the tennis from your laptop or PC

We are being sold the ability to spend money we don't have. And we love it

HTC's head designer on what's exciting in designing for mobile right now

Apple Music preview: Why Spotify should be scared of Apple's impressive new music-streaming service

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message