SP2 interferes with screen resolution

  TimCDC 08:25 25 Mar 08
Locked

Our family have inherited an old computer, with XP pre-installed. All works fine until I install SP2, when the screen resolution drops from 1024 x 768 to 640 x 480 and the colour depth drops too. When I go to the display panel in Settings, it won't let me increase the resolution. If I de-install SP2, all works fine again.

Display properties > Settings tells me I am running a default monitor - could that be the problem? I can't update the driver for the monitor as it is a gnr F153 and doesn't need a driver. This means that when I go to device manager, there is no monitor option for me to try to update.

At the moment, I am stuck between a fully updated machine that you can't see anything on, or a machine running SP1 with all the problems, but with a decent resolution.

I'm sure there is an easy solution...but I just don't know what it is!

  jimv7 09:16 25 Mar 08

You need to reinstall the graphic card drivers after sp2 install.

  TimCDC 09:33 25 Mar 08

Thanks Jim.
In order to find where to go to update the graphics card, I ran the Direct X diagnostic tool. On the display tab, it simply tells me that I am running the vga.dll driver (and elsewhere says that "The system is using the generic video driver. Please install the video driver provided by the hardware manufacturer" but in the device area of the same tab it gives nothing by the name and n/a by the manufacturer, chip type and DAC type. How would I go about finding where and how to update the driver?

  xania 09:43 25 Mar 08

If you have on-board graphics, the drivers would be on the Motherboard drivers CD. If you don't have this, you should be able to download the latest drivers for your motherboard from the mobi website. In the same way, if you have separate graphics card, the manufacturer's website will have the latest drivers.

  ambra4 10:29 25 Mar 08

Download SIW install and run click video and all the information on the video card will be available

click here


Download driver and install

  TimCDC 10:39 25 Mar 08

Thanks Xania and Ambra
I've discovered I have a Microstar motherboard running an intel i845 chip. Going to the Microstar website shows me that of the 22 drivers on the machine, 8 are out of date. In order to update them it wants to charge me $23. I'm wary of paying this as I am not 100% sure it will resolve the problem and also hope I might be able to get the drivers for free. However, if this is what I need to do, then I shall do so. Any advice?

  jimv7 10:47 25 Mar 08
  TimCDC 10:58 25 Mar 08

Jim - I can't get that site to work at the moment, but will check back on it later...thanks for the lead.

  jimv7 11:25 25 Mar 08

Google for 'intel i845 xp drivers'

  TimCDC 12:36 25 Mar 08

I've tried multiple sites now to download new drivers. Each one gives me a message, "Internet Explorer cannot display this page". I've tried this on both the dodgy computer and another one in the house which works just fine. Can't get through on either. Aaagghh!

  ACOLYTE 14:06 25 Mar 08

I have never know SP2 to alter the graffix driver on my machine,but i have a slipstream version so it all gets installed together.
If you have a driver that works then i cant see why SP2 would remove that driver and use another with less functionality,have you tried rolling back the driver to what you had?,dont know if it would work but might be worth a try,create a restore point first just incase.

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Best Design, Illustration, Animation and VFX Awards of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced