Sound SB0090 and Win98se

  zoobie 17:15 22 Mar 05
Locked

I popped a sound card (SB0090) in and my Windows98se said it detected it...but couldn't read a file on the cd-rom drivers (missing Disk.ID file) and quit. I've downloaded the drivers into my download folder and tried clicking "setup" without success. In fact, I've tried every which way I can to install drivers for this card without success. The main message I always get is that the computer "cannot detect any sound card" installed. This is strange because it's seen on startup and even registered in the device manager under "other" with a large yellow ! beside it. Yet, Windows says it can't detect it.

It's a Creative Sound Blaster SB0090 card that's evidently discontinued...Gee, I wonder why?

I bought this card used and am had serious doubts when I plugged it in...not that the card wouldn't work...rather the included drivers on the burnt cd-rom.

Thanks for any help

  zoobie 20:53 22 Mar 05

Anyone have any ideas?

  ton 21:16 22 Mar 05

Download new drivers from the Creative site. Make sure you get the correct ones (0090).

  zoobie 03:08 23 Mar 05

"setup.exe cannot detect any sound card...check hardware"
I've tried different slots...same message.
This card is old and I've dl'ed every driver on the web...which isn't many.
The IEEE port on this card intalled...yet windows doesn't see the audio card.

  zoobie 03:26 23 Mar 05

...and you can't install any drivers if the card isn't detected...it just exits.

  zoobie 14:42 23 Mar 05

It's told me via the latest dl that it wants Win2000 or higher. I've contacted Creative for an original installation disk for this card seeing as it lists Win98se as a valid OS. I could always buy Win XP seeing as I've reached my limit with Win98se...

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now