Sound Drivers for Dell D620 installation Problem

  Amicable1 10:44 AM 21 Sep 13

Dear Members

I am new to this site specially for posting something. I don’t know I should post this question in this section or not. However my question is regarding Laptop drivers. Specifications of my Laptop are:

Dell Latitude D620 Genuine Intel (R) CPU T2400 @ 1.83 GHz (Dual Core) 01 GB Ram 80 GB Hard Drive OS : Microsoft Windows XP Professional Version 2002, Service Pack 03, V.3244

Recently I have installed fresh copy of windows; almost all drivers have been installed successfully except sound which has given me very tough time so far. I have tried almost everything to install that but all in vain. If any member can help me out regarding this problem I will be really thankful.

P.S.: Sound card driver’s downloaded file (R171789) from Dell’s official site is not working either and quits during installation, though drivers shown installed in Add remove program but doesn’t work and no sound at all on the other hand PCI device is shown with a “?” sign in device manager.

Please help.

Thanks in advance.


  rdave13 12:07 PM 21 Sep 13

Not sure if this is the same driver version from here.

  Procrastinus 12:12 PM 21 Sep 13

Any help here? Dell Support Forum

  Amicable1 17:31 PM 21 Sep 13

Thanks a lot to both of you Rdave13 & 608 that you both tried to solve the problem.

But unfortunately its not settled yet.



  lotvic 18:02 PM 21 Sep 13

Read this info and maybe try this customized version click here


This thread is now locked and can not be replied to.

Best Black Friday deals 2015 live blog: Best UK Black Friday deals & best UK Black Friday tech…

1995-2015: How technology has changed the world in 20 years

HDR video: Everything you need to know

20 Mac Power User Tricks... That You Didn't Know