Sound Card won't work

I've installed A new Philips dynamic edge 4.1 sound card on my pc (celeron 600 running Xp home).
Windows recognises new hardware but when I try to use sound I get a 'Initialization error failed to open PSA2 driver' message. Can anyone help?

  Ironman556 19:38 25 May 03

First thing to try would be to go to the Phillips website and look at their FAQ's and help section. It may be a known/common problem, in which case you'll probably get an immidiate solution.

Did you close everything before you installed? Anti-virus etc. If not then remove the card from windows, set all the programs which run on boot not to start automatically, restart the computer and re-install.

If that fails copy the installation files to hard disk and install in Safe Mode.

If you still can't get it working try the latest drivers from Sony, the drivers can be outdated even if you've just bought the product.

Finally, try emailing Phillips Technical Support and see what advice they can give you.

Good luck, Ironman.

  Lú-tzé 19:40 25 May 03

What is your OS? It might make a difference.

For now, have a go at reinstalling the software - see what happens.

Also, try running system file checker:

start_run sfc /scannow

  Ironman556 19:44 25 May 03

- try the latest drivers from Phillips -

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Switch price…

1995-2015: How technology has changed the world in 20 years

Best Photoshop video tutorials: 8 video tutorial websites for Photoshop

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…