Sound card in laptop gone missing...

  prb 21:17 27 Jun 07
Locked

Sound no longer works in my Acer Aspire 5050 laptop. It stopped working, and there was nothing obviously wrong witht the settings, but since I was planning a clean reinstall of everthing anyway (returning to XP after trying out Vista for a couple of months - didn't really have the memory to run it properly and kept locking up) I decided just to reinstall everthing from recovery discs.

Once reinstalled sound still didn't work, but it's not even showing as a faulty component in the Device manager. Simply inserting a CD in gives a message to the effect that there is no sound card installed.

I intend to call Acer tomorrow anyway since its still under warranty, but wondered if anyone had any other suggestions on what I could try?

Thanks

First check the BIOS to make sure the onboard sound hasnt been disabled. (Depending on bios type there may or may not be such an option listed). That would explain why it isnt listed in the device manager. Make sure you have the latest motherboard / system drivers from the Acer website.

  ambra4 00:46 02 Jul 07

Try installing sound driver from recovery disk from acer if you have one

You will have to search the disk and find audio drivers

  Stuartli 08:17 02 Jul 07

According to the model's specifications, it has a SoundBlaster Pro high definition support sound card (graphics is described as ATi RadeonĀ® Xpress 1100 integrated 3D graphics) and not an onboard sound chipset.

The Creative website should have the latest drivers, but also features an AutoUpdate facility which may prove helpful. See:

click here

  Stuartli 08:20 02 Jul 07

Creative's AutoUpdate, by the way, at present doesn't support Vista for those who may be thinking of having a look at the link.

  prb 09:26 02 Jul 07

Thanks everyone, have already tried a complete reinstall and not been effective. Never thought to check the BIOS so will have a look tonight but since I've never entered the BIOS on that computer I guess it would be unlikely.

Have just dropped an email to the place I bought it so hopefully will be moving forward soon! Other slightly concerning thing is that the ports for the soundcard (speaker, mic, line in) are getting very hot during use of the computer, so I suspect it may be an actual hardware problem on the soundcard.

Thanks again,

Paul

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Why ecommerce hasn't taken off on social media

New MacBook Pro 2016 review | MacBook Pro with Touch Bar review: Apple's expensive and powerful…