Sony Vaio VGN-TZ31WN/B HDD Replacement

  wozza_c 09:45 AM 06 Nov 12

I have a Sony Vaio VGN-TZ31WN/B that has started to report a faulty hard drive. After some research on the net i bought an identical replacement 120Gb 1.8" Toshiba ZIF drive.

I have attempted to replace this drive 3-4 times now and no matter what i do, the new HDD is not recognised i the BIOS. I know that i am doing the replacement correctly as i can reconnect the old drive and it is recognised straight away.

I have also tried to connect a 120Gb 1.8" ZIF SSD but with no luck.

Does anyone know if there anything that i need to do to "initialise" the new drive or am i missing something entirely?

Any help would really be appreciated.


  wozza_c 10:44 AM 06 Nov 12

Hi Jock1e,

Thanks for that. I have checked and the HDD replacement and it is exactly the same model as the original. As you say, its pretty tricky to replace these devices anyway, still i can get the old one working again, just not the new one :(


  Fruit Bat /\0/\ 13:40 PM 06 Nov 12

If BIOS sees old drive and new drive is connected correctly with power and data cables then it looks like the new drive is faulty and should be returned for replacement.

Can you feel the new drive spin up / get warm?


This thread is now locked and can not be replied to.

Best Black Friday deals 2015 live blog: When is Black Friday & what are the best tech Black Friday…

1995-2015: How technology has changed the world in 20 years

This is the animated Christmas ad everyone's tallking about

20 Mac Power User Tricks... That You Didn't Know