Some Design not showing in Dreamweaver

  griffo 17:22 PM 02 Feb 09

I am using DW CS3 and have been working on many pages to update our website. However, I have come across one page which, when opened in either 'split' or 'design' view, only shows the top part of the page - the rest of the design isn't showing.

Can anyone suggest a remedy please?

  Kemistri 22:37 PM 06 Feb 09

Two caveats first: I don't use DW and I can't see your mark up.

But I guess that there is a major error somewhere in the mark up that corresponds to the point at which the content goes MIA. Have a go at validating it.

  griffo 10:32 AM 07 Feb 09

Thanks for the reply.

I have tried a validation and it's awful - 172 errors and 12 warnings!

I'm happy to work on this to try to put it right but it would be so much easier (I think), if I could at least fix enough to get the design to appear in DW.

I presume that, if I can correct the 'vital bits' in DW, the design should then appear?

  Kemistri 14:07 PM 07 Feb 09

Without seeing the validation report, I can't comment specifically, but you should find that many of its reported errors are a result of one simple error in the mark up itself, such as: a tag that has not been closed; a missing tag; a missing DTD (doctype declaration); etc.

  ethelbert 18:01 PM 09 Feb 09

If this ever happens to me, I take out the content minus the <divs> and put this into Notepad, and then delete the offending page. I then make a new page and add the content - if you are using dwt, I then validate the page before adding the dwt.


  griffo 09:20 AM 10 Feb 09

That sounds like a plan - thanks (quite a lot of content though).


This thread is now locked and can not be replied to.

Best Cyber Monday deals 2015 live blog: Best UK Black Friday weekend deals & best UK Cyber Monday…

1995-2015: How technology has changed the world in 20 years

The best Black Friday Deals for designers and artists – updated

20 Mac Power User Tricks... That You Didn't Know