SM Bus Controller

  stlucia 11:19 06 Dec 09
Locked

Having sorted out a couple of other yellow question marks in my Device Manager, I've still got one against SM Bus Controller.

I've Googled "SM bus controller", and I get several links to Intel sites. I've tried following the "identify your chipset" instructions on the Intel site, but no chipset is listed in my Device Manager > System Devices, which is where they say it should be identified.

So, what exactly is a "chipset", please? My main processors are two Athlon 64 X2 Dual Core Processor 4600+. Are those what they mean by "chipset", in which case I need to be looking for an Athlon solution to my SM Bus Controller issue?

My PC is an HP Pavilion a6525.uk.

  Fruit Bat /\0/\ 12:44 06 Dec 09

IS ths the machine you are trying to load XP on?

HP do not have the XP drivers for this machine.

nVidia nForce 430 chipset motherboard with 2MB L2 cache and 2000 MHz FSB.
click here for drivers for XP which include
SMBus driver version 4.50 (WHQL)

  stlucia 19:07 06 Dec 09

Yes, Fruit Bat /\0/\, the same machine. It's been working fine with XP for several months, until I got the flight simulator which wouldn't work. So I thought it's now time to sort out all the yellow ?s.

I'd sussed that HP have no drivers for XP, but I was confused about what on earth "SM bus controller" refers to, and what "chipset" refers to. I'll check out your link, and the nVidia web site if I need any further info.

Thanks for your help again :-)

  stlucia 22:17 06 Dec 09

I've downloaded the driver version 4.50 from the link, and it seemed to install okay (no error messages). I've then used Device Manager to uninstall the SM Bus Controller driver, and then to reinstall the driver. But it fails because it says it can't find the necessary driver, even if I manually point it to the folder which the download has just dumped some new driver files into. When it fails, it doesn't give me the name of the file it's looking for, so I can't get any further.

According to my manual, the "chipset" is "GeForce 6150SE nForce 430" (as you said above, Fruit Bat /\0/\), so I've gone to the GeForce/Nvidia site looking for drivers. But their selection process doesn't recognise either GeForce 6150 or nForce 430.

I then Googled "GeForce 6150SE nForce 430" and got this site click here which looked promising. But after dowloading, when I ran it it stopped saying it couldn't find any hardware compatible with the drivers.

Anyone any more ideas, please?

  stlucia 20:04 07 Dec 09

Any more ideas, please?

  GaT7 20:15 07 Dec 09

"I've downloaded the driver version 4.50 from the link, and it seemed to install okay (no error messages)."

So all is fine.

"I've then used Device Manager to uninstall the SM Bus Controller driver, and then to reinstall the driver."

If it went OK above, why did you uninstall it?

Anyway, may be I've misunderstood. Try these drivers instead click here. G

  stlucia 08:27 08 Dec 09

... that's done it, Crossbow7. No more yellow ?s in Device Manager. Thank you.

I see now that, even though there were no error messages, the previous installers I used hadn't worked because they just got as far as the Nvidia screen and then shut down after a few seconds. I had thought that signified job-done, but it obviously wasn't.

I then used Device Manager to uninstall and reinstall because I thought that Nvidia has simply placed new drivers on my PC, and that's what Device Manager then recommended if you're having driver problems.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac