SM Bus Controller

  feb 14:57 26 Sep 08
Locked

Hi All

I'm having problems finding a driver for the SMB Controller.
MB: Asrock GE Pro HT
Chipset: SIS 651
CPU: Intel P4
XP Pro

Intel do not recognise any thing and I can't find any information on the Asrock web site.

Any help Gratefully received!!

  Eric10 15:06 26 Sep 08

click here for drivers. Installing the IDE drivers should fix it.

  feb 15:25 26 Sep 08

Thanks Eric10, I've installed all of those drivers and have just installed the IDE driver again, still no luck.

  GaT7 16:47 26 Sep 08

Don't worry about it if your system functions normally & there are no problems/exclamation marks in Device Manager.

I've been running a few scans (since this thread click here), but they're all unreliable, or 'fussy' at best.

The scans tell me that there are ~8 components that need updating - including the SM Bus Controller - but I'd say all the updates are minor. My system works like a dream, & I'm not going to screw it up by installing every little update some scan thinks I need - I'd strongly recommend you doing the same.

Also be aware that some of the update links the scan(s) directs you to, provides the WRONG drivers, or changes the language of items in device manager! If you MUST try them, make sure your System Restore is working & set a restore point BEFORE making any changes each time.

It would be best to visit the manufacturers' websites & only install the updates available there. G

  feb 17:16 26 Sep 08

HI Crossbow7
Therein lies the problem, I have no sound!!

After I made some stupid driver updates the sound disappeared, I re-installed the original Mobo drivers and still no sound, I updated from the Asrock website and still the same.

The SM Bus controller is the only problem I can find on the PC so I thought I would try and eliminate that before going on.

  GaT7 18:01 26 Sep 08

Using System Restore, revert your system to a point/day before you installed these updates.

Failing which, do a 'Roll Back' of the present audio drivers & reboot.

If still no joy, completely uninstall the present drivers, install the ones from click here & reboot. G

  feb 18:48 26 Sep 08

The first thing I tried was system Restore, It couldn't go back!
I then rolled back all of the drivers but still no joy!
I then uninstalled all of the drivers and re-installed the drivers from the original disc, no joy!
I then uninstalled the original drivers and installed the drivers from the Asrock web site, still the same!!

I've been at this for two days now and I'm stumped, any fresh input would be welcome!

  feb 19:05 26 Sep 08

Still no SM Bus Controller, but the sound is back, info from this site click here seventh post down, efi!!

  skidzy 19:09 26 Sep 08

For what its worth i rebuild P4's using Asrock boards and your issue often occurs.

This is a common problem and normally a visit to MS updates will sort this issue...dont ask why-i dont know the answer :-)

Failing that,try installing everything on the drivers and utilities disc that comes with the Asrock board.

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now