Slow Internet over network when Vista is running

  CLONNEN 17:26 16 Sep 07
Locked

My brother has recently changed his computer from an XP Desktop machine to a brand new Vista Laptop. It is connected to a wired network over which we share our broadband internet access.

My computer is an XP Desktop which usually brings up web pages more or less instantly. I sometimes get some slowdown in the evenings but this is quite normal.

Whenever my brother uses his Vista Laptop for internet gaming or downloading games, the loading of web pages on my computer slows down to an absolute crawl. A lot of the time I now get Unable to Connect messages.

We never had this problem when he was on the old XP machine. How can we get Vista to not hog all the bandwidth to itself?

  Ashrich 00:17 17 Sep 07

The router is prioritising the downloads , or not as the case might be ....see if in the router set up pages you have something like " traffic smoothing , QOS settings or similar and if necessary turn them on , or off and see if it makes a difference .

Ashley

  CLONNEN 13:25 17 Sep 07

We were using the same router when he using the old XP machine so I don't think changing the router settings will help. I'll have a look when I get home though.

Are Vista's default network settings different to XP's in some way?

  ambra4 20:17 17 Sep 07

Change the Lan card Speed set-up on both PC

Start-Network Connection-Local Area Connection -Properties

At the top of display the type of Lan card will be displayed-Click Configure- Click-Advanced

In the box listed below click Connection Type – In the value box change the setting from Auto to 100 base Tx Full Duplex.

  ambra4 19:25 29 Sep 07

How to fix Vista's network bottlenecks

The problem with Vista's new-fangled network stack

All this automatic tuning of the Vista network stack sounds great in theory

But the problem is that some clients don’t support TCP window scaling

Or don’t have it enabled.

Additionally, some firewall products also don’t support it.

In either scenario, the result is dropped packets, which affects network performance horrendously

Your traffic is literally dropping into a black hole, never to be seen again.

If you’re experiencing excessive network lags on Vista

If using McAffee uninstall and turn off IPV6

Do this opening up an Administrative Command Window

Right-click-Run as Administrator and type in the following command:

netsh interface tcp set global autotuninglevel=disabled

You may also need to type in:

netsh interface tcp set global rss=disabled

The changes take effect straight away, with no reboot needed.

You can also check this site

click here

This thread is now locked and can not be replied to.

Surface Pro 5 News - release date, UK price, features, specs

Microsoft Surface Studio hands-on review: the iMac killer is here

Best Mac antivirus 2017