Slow Hard Drive

  ivesy 20:35 07 Apr 05
Locked

I've just ran a utility which has said my Hard drive is running slow and that the processor utilisation might be high. I ran the utility because i've thought for some time the Drive has been slow. I have recently defragged the drive but that has made no differnce. Scan disk doesn't show any errors. The drive I have is a Western Digital WD1200LB 112GB which is about half full/empty running on a P4 2.6 PC with 1024MB memory. Any ideas how I can fix it or do I just need a new drive?

  Fruit Bat /\0/\ 20:43 07 Apr 05

Check device manager is the IDE channel the drive is on using DMA or PIO?

  DieSse 22:29 07 Apr 05

You could be getting read errors which will slow a drive down, without showing it as failed. A good test can be had here click here (free trial available)

Before you run this go into the BIOS and enable SMART for the drive, if it's not already enabled.

  ivesy 19:25 08 Apr 05

It's using PIO mode 4. I've just used the program Active Smart and that says it is on Good Status. Thanks for the replies by the way!

  Fruit Bat /\0/\ 19:42 08 Apr 05

Method a) — Uninstalling the Port
1. Uninstall the secondary IDE port
To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

Reboot to make the changes active and permanent.

After booting Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

2. Reactivate DMA
But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

On Windows NT and 2000 you now have to reboot a second time, but Windows XP applies the change instantly. Then you can go to the same place in Device Manager again and check whether the device is now actually using DMA mode. If so, all is well.


Alternative method === Re-enable DMA using the Registry Editor

Run REGEDIT. Go to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…