Skype USB phones and noise

  exdragon 15:55 08 Jan 06
Locked

Still having problems with a pair of Skype USB phones, making calls either in the UK or abroad. I get my own voice repeated at the other end, but the person I'm calling (in the UK) doesn't have any such problem and doesn't get this repeating. We both have the same type of phone.

I can understand this happening when I call my daughter in New Zealand, as she just talks in the general direction of the computer and webcam!

I've tried changing the Sounds and Audio Properties from RealTek to USB Generic, and also changing from 5.1 sound to no speakers, but no matter what I do I still get lots of crackles, sibilance and echo.

Have I missed something obvious, please?

  MichelleC 16:04 08 Jan 06

Realtek is the better choice.

Are you xp or w2k, and is it onboard sound?

  dms05 16:18 08 Jan 06

I recently bought a USB phone to use with VoIP services. I set Generic USB Device in all the sound settings as the USB Phone has it's own Sound Card and it seemd poimtless by-passing that. I no longer suffer from echo at all.

Have you opened Control Panel - Sound/Audio and then gone to the Voice tab and under Voice Recording (ie your voice going out through Skype) gone through the diagnostics under the Buttons:
Volume Advanced Test Hardware

Your voice volume going out may be set so high your getting some feedback from the other end.

I seem to remember the latest version of Skype has a 'let Skype control the sound' type setting that you could try. Under Tools / Options / Sound Devices.

  exdragon 16:22 08 Jan 06

MichelleC - I've got a sound card and XP home

dms05 - thanks for the suggestions, I'll have a poke around in Control Panel, although when I tried the phone just now, it was completely dead...

  Stuartli 16:45 08 Jan 06

My headset works perfectly with the Skype Echo Test yet, strangely, I always have to have the mike input muted...:-)

Sometimes, on long distance calls, I get an echo of my own voice and other times it's as clear as a bell.

The person at the other end has no such problems.

  Stuartli 16:48 08 Jan 06

Just tried the Skype audio help pages - says mike should be muted...:-(

  exdragon 16:49 08 Jan 06

Thanks one and all - I've done as dms05 suggested. The volume was set far too high. My other half says thanks too - he's been getting fed up with me ringing him to test it out!

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…