Site feedback

  nordickids 22:31 21 Mar 06
Locked

Hi,

Been lurking a while and finally posting now...

I've been working on an ecommerce site to sell baby clothes and accessories using Actinic, which has been mentioned here a couple of times. The site is at click here

I've seen the helpful people here critique other sites and so I was wondering if you could do the same for me? There's still lots and lots I want to do to it but I feel it's at the point where some feedback would be really helpful. It's the first time I've built a site completely so it has been quite an interesting learning curve!

Many thanks in advance.

  Forum Editor 00:12 22 Mar 06

and for a first attempt it's very good indeed. A couple of initial reactions:-

1. Your homepage would benefit enormously from having some images. People buy with their eyes, and where websites are concerned that's especially true. Hook visitors with an attractive image or two, but be careful. As I'm sure you're aware, you must be especially cautious with images of children on the web, and my advice would be to stay away from anything that shows a child alone - either go for a nice group of kids, or show a child with a mother.

2. Include an internation dialing code prefix on your phone number. Always think internationally when designing an e-commerce site. That way, you'll look friendly to a potential customer in Osaka, or Shanghai, or any one of a hundred different locations around the world.

3. Free deliveries on orders over £35 - do you really mean that? I recently sent an air-freight parcel of documents and CDs to a client in Fiji, and it cost £18:50.


I like your terms and conditions and privacy text - you've covered the ground well.

  nordickids 21:26 22 Mar 06

Hi,

thanks for the review FE. Images to the home page was on the list of things to do but I'll make it a priority.

re: points 2 and 3, at the moment we are only shipping to the UK for reasons related to the business. Obviously it would be great to expand that out at some point but to start with we're UK only. However, looks like I need to make that much more explicit!

fourm member: hmm, looks like my host is having a few glitches today (typically the first day I've sent the link out to people... it's been 100% up until now!). Seems to be alright now though. Thanks for the warning though, I might have missed that otherwise.

  nordickids 09:37 23 Mar 06

Hmm, this is a bit strange and slightly worrying as it was working for me last night and I can see if fine as well now.

Anyone have any suggestions as to why it may be down for one person but live for another? What should I be asking my host?

Thanks!

  GroupFC 15:34 23 Mar 06

Just to put my two pennies worth in - fourm member, I have been following this thread with interest - are you sure that the problem isn't at you end as I have been able to get the site every time I have tried (both in IE & Firefox)!

  Mr Mistoffelees 16:53 23 Mar 06

Works well with Opera 8.52

  nordickids 19:45 23 Mar 06

I've downloaded and installed a copy of Netscape 4.75 to see what happened and I can access the site but have to admit it's none too pretty... plenty to work on there!

Thanks for pointing out the local references, I know exactly what has caused them (sloppiness on my part when hacking together the home page) and will correct them this evening. They should only be on the home page though, on all the other pages the references should be correct. What happens if I direct you to a page deeper linked than home, can you access that? Please could you try this:

click here

I suspect that you are correct and it's the local references combined with the fact you have actinic installed causing the problems.

Thanks for all the input and your help so far everyone!

  DrScott 09:10 24 Mar 06

I'm using Opera and can see the site just fine, but I see what you mean about the local references.

Still that doesn't explain why John can't see the page and everyone else can?!

  nordickids 02:09 29 Mar 06

Sorry for the delayed response, had a bit of a nightmare with NTL...

Turns out the local references were down to me using uncompacted html within Actinic when i was messing around with the templates. I've changed it back to compacted and re-uploaded and so they should be all gone now (hopefully!).

fourm member: if you still have patience for this, can you see the site now?

  nordickids 22:27 29 Mar 06

Very strange indeed as I can't see any across the site now in IE or Firefox. This may be a long shot, but could it be that you have the pages cached? When I make an update to the site I always have to do a hard refresh before I see the changes (in fact, I found some local references in one page style just now but they disappeared after I did that).

You're right about Actinic though, it is very good but also extremely quirky and you can do all sorts of damage with an innocuous looking change!

This thread is now locked and can not be replied to.

Sony Xperia XZ Premium review: Hands-on with the new 4K HDR phone with Motion Eye camera and Snapdr5…

1995-2015: How technology has changed the world in 20 years

Best laptop for design and art 2017: we test Apple, Dell, HP, Lenovo and Microsoft's best models…

CarPlay tips & troubleshooting guide: CarPlay tips & troubleshooting guide: Get the most from…