Sims 2 Missing .DLL file

  Jim H 10:31 28 Dec 04

Morning all,

Hope you all had a great Christmas. I installed my daughters new Sims 2 game and after installation, when I try to run the game the following message appears;
"A required .DLL file, D3D9.DLL, was not found"

I have uninstalled the game and reinstalled but the same message appears. Windows Me, 1.5ghz, P4, Nvidea graphics, creative sound card.

Thanks for any help


  VoG II 10:38 28 Dec 04
  Jim H 10:53 28 Dec 04

Hi VoG

Thanks for the help. I downloaded the file and transferred to CD to install on my daughters computer. Installed by winzip, it recognised the sims directory for the transfer but when I tried to restart the game the same error appeared.

  VoG II 10:58 28 Dec 04

Try putting it in c:\windows\system

  ACOLYTE 11:01 28 Dec 04

You may be better re installing directx this file should be installed with that.

  Jim H 11:09 28 Dec 04

VoG, did what you said and when I now try to start the game I have a new error message;
"The D3D9.DLL file is linked to missing DDRAW.DLL:DdEntry21"

ACOLYTE, I tried to install directx9 which camewith the game and had the following error message;
"A cabinet file necessary for installation cannot be trusted"

  ACOLYTE 11:35 28 Dec 04

Sounds like a corrupt/incomplete Directx9 instalation,you could try dloading it from microsoft click here

  ACOLYTE 11:39 28 Dec 04

click here

Sounds like this is a regular error with the sims.

  Jim H 12:30 28 Dec 04


Downloaded Direct X 9c but still has the same error message when I try to install!

Any way round this?



  ACOLYTE 12:45 28 Dec 04

Try start run and type dxdiag in the run box
then check the files for direct x are all ok then
goto the display tab and make sure that direct draw and direct 3d are enabled and run the tests
to see if it passes.

  Jim H 13:01 28 Dec 04


direct draw - passed all tests
Direct 3d
- 7 test results - Failure at step 8 (creating 3D device) HRESULT - Ox8000405 (generic failure)
- 8 test results - Failure at step 8 (creating 3D device) HRESULT - Ox8876086c (error code)
- 9 test results - Failure at step 8 (creating 3D device) HRESULT - Ox8876086c (error code)

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Switch price…

1995-2015: How technology has changed the world in 20 years

Best Photoshop video tutorials: 8 video tutorial websites for Photoshop

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…