Sharing internet from wired LAN to Ad hoc

  Charence 21:45 17 Mar 06
Locked

Currently I have a PC which connects to the internet via a network cable connecting it to a LAN which has the internet. My computer has a wireless NIC as well which is currently not in use, I would like to know if it is possible to share the connection from the wired LAN to a wireless ad hoc network?

I've been looking around the forum and the net and haven't managed to do this yet.

The computer connected to the wired network is running XP Home, the wireless device I wish to connect is running PalmOS 5.

Many Thanks,

Charence

  mgmcc 22:09 17 Mar 06

Yes, this should be possible. Enable "Internet Connection Sharing" on the PC's ethernet connection to the Lan. This will automatically configure the Wireless Network Connection with the IP address 192.168.0.1 and Subnet Mask 255.255.255.0. The "client" device gets its IP address by DHCP from the "host" PC.

One thing though, because "Internet Connection Sharing" uses the 192.168.0.xxx subnet (IP address range), the LAN you have the PC connected to will have to operate in a different subnet, such as 192.168.1.xxx or 192.168.2.xxx

  Charence 23:11 17 Mar 06

When I try to make my computer obtain an IP and Subnet automatically it doesn't seem to work properly. It retrieves an Automatic Private Address which has the address 169.254.252.145 and subnet 255.255.0.0 and everything else is not filled in. The internet doesn't seem to be shared. Here's my current details:

Wired LAN (ICS enabled)

Type: DHCP; IP: 129.31.64.160; Subnet: 255.255.254.0; Gateway: 129.31.64.1; DNS: 155.198.63.100

If I manually configure the settings on the wireless network, what should I enter for Gateway and DNS? I've filled in 192.168.0.1 for IP and 255.255.255.0 for Subnet mask.

Thanks

  mgmcc 14:06 18 Mar 06

<<< When I try to make my computer obtain an IP and Subnet automatically it doesn't seem to work properly. >>>

No, you have misunderstood me. You need to enable "Internet Connection Sharing" on your ethernet connection to the LAN. In the Network Connections folder, right click the LOCAL AREA CONNECTION, select Properties and then the Advanced tab. Tick the box "Allow other network users to connect through this computer's Internet connection". When you do this, Windows will automatically allocate the *fixed* IP address of 192.168.0.1 and Subnet Mask of 255.255.255.0 to the WIRELESS NETWORK CONNECTION. You don't manually configure any of the TCP/IP settings.

<<< If I manually configure the settings on the wireless network, what should I enter for Gateway and DNS? I've filled in 192.168.0.1 for IP and 255.255.255.0 for Subnet mask >>>

The point is that WINDOWS must configure the Wireless Network Connection, not you.

To sort this all out again:

Go back into the LOCAL AREA CONNECTION settings and disable ICS again (untick "Allow other users etc). "OK" that box to close it.

Now go into the WIRELESS NETWORK CONNECTION's settings and set it to get its IP address automatically. "OK" the box to close it.

Once again, go into the LOCAL AREA CONNECTION settings and enable ICS (tick "Allow other users etc). "OK" that box to close it.

At this point, the IP address of the WIRELESS NETWORK CONNECTION should have been changed by Windows to 192.168.0.1 which you can check at the bottom left of the Network Connections folder as click here

  Charence 00:35 19 Mar 06

I've managed to make the wireless connection automatically obtain the correct settings now, unfortunately my wireless device seems to be having problems obtaining the correct details automatically. It keeps trying to set the subnet as 255.255.0.0

Thanks

  mgmcc 08:10 19 Mar 06

If the client device has a Subnet Mask of 255.255.0.0 then it probably also has an IP address in the 169.254.xxx.xxx range. This means that it hasn't managed to get its IP address from the PC. Unfortunately, I know nothing about Palm OS and so cannot tell you how to connect one to a Wireless Network.

  Charence 04:56 20 Mar 06

I've now managed to make the palm automatically obtain the correct IP address, etc. Sadly, the device seems unable to connect to the net...maybe its a problem with the device. Anyway, thank you so much mgmcc for your help.

Charence

  Charence 05:00 20 Mar 06

I've just noticed that file sharing is working now!

thanks again

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Best Design, Illustration, Animation and VFX Awards of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced