Sharing Broadband with Zonealarm

  Joe R 12:05 19 Feb 06

Hi all,
I have just connected my own system, to my Kids System using a cat crossover cable, and set up a network, so that they are able to share my broadband connection.

Everything went well, except for the fact that, I have to turn my Zonealarm firewall off on my own P.C., so that the kids can access the net. I've added their system to the trusted zone in the firewall, but still cannot get access for the other machine unless, I turn the firewall off.

Can anyone tell me how to share access, with my firewall turned off.?

P.s. Both pc's are protected by Avast as well as Zonealarm.

  Joe R 12:22 19 Feb 06

Can anyone tell me how to share access, with my firewall turned off.?

That should read, Can anyone tell me how to share access, with my firewall turned on.?

  DrScott 12:43 19 Feb 06

Has caused be probs in the past. The one fix that worked for me was reinstalling it with all computers on the network. The other thing that might work is changing the zone of the other machine from trusted to internet.

  Joe R 12:46 19 Feb 06


the other machine was originally on "inernet" but with the same problems.

I'll try reinstalling, but if this does not work, i'll just run my own without a firewall.

  mgmcc 13:12 19 Feb 06

In Zone Alarm in the "host" PC, you need to reduce the "Internet Zone Security" level from High to Medium or "Internet Connection Sharing" traffic will be blocked.

  Joe R 13:22 19 Feb 06

I've already tried this with zonealarm, and even had it at the "lowest" setting, but with no success.

  mgmcc 13:29 19 Feb 06

OK, also in Zone alarm, in the Trusted Zone of both PCs, click "Add" and select "Subnet". Enter:

IP address -

Subnet Mask -

Description - {anything} but it needs an entry. Click "OK" and then in the main window "Apply".

  Joe R 13:56 19 Feb 06


Thanks, tried this solution, but still no joy.

  DrScott 14:45 19 Feb 06

And if that doesn't work, just use the Windows XP one that comes with the OS. As long as your virus checker and spyware scans are working, that will give you some protection.

Not having a firewall at all, especially with broadband, is rather unwise.

  Ray5776 17:51 19 Feb 06

Unlikely but worth checking,ZA/program control/generic host. Make sure generic host is not blocked.


  Joe R 19:19 19 Feb 06


Thanks for the input, but everything is ok there. I'll have another go later on, and see what else I can come up with.

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…