Setting up wireless security D-Link G604T

  Madraykin 16:06 29 Sep 06

Hi guys,

I'm not a computer whizz (well, the technical side anyway!), and have just been bought a brand new Acer Travelmate 2420. It connects fine to the wireless internet through the above router, but once I try and secure it I just can't log on. I've browsed around a load of forums gathering little snippets here and there for things to change/try, but nothing has worked. I've got it to a point where it tries to verify my identity, but isn't able to - it's not asking me to enter a password/key to log on, which I thought it would. Sorry if this sounds really stupid, but I'm need of some serious help before I go insane!!

Any advice would be much appreciated!


  ade.h 17:19 29 Sep 06

Read my guide: click here

  iashem 18:27 29 Sep 06

i know it sounds silly but are you trying to change the security settings wirelessly because the above mentioned router does not allow settings to be changed unless you are connected via ethernet cable

  handful 12:53 02 Oct 06

As iashem says it is better to make changes via ethernet although I could connect to my dlink if I positioned it very close to the pc/laptop in question. I think it basically needs a very strong signal to even recognise that a WEP key is needed and if you are close enough it asks you to enter the key to connect.

  ade.h 14:18 02 Oct 06


  Madraykin 11:22 03 Oct 06

Sorry I haven't been back guys, and thanks for the help!

It turns out I had been very clever and set up WPA-PSK security all on my lonesome. I realised in the shower that evening (it was a *doh* moment) that the only reason it wasn't working was that the laptop was still set on looking for WPA - so I just changed that to WPA-PSK and voila!!!

I'm quite proud of myself!

  Strawballs 11:45 03 Oct 06

Well done feels good doesn't it but can you you tick this as resolved.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac