Scheduled tasks not running under different users

  Markdym 11:23 24 Sep 03


My WinXP (SP1) computer belongs to a domain. I have several scheduled tasks set to run under my (admin) account. I would like one of these tasks to run no matter who is logged on.

I have seen in the 'Help and Support' that scheduled tasks will run when a different user is logged on but that the task will be invisible. Is there a way that I can set a scheduled task to run and be visible no matter who is logged on? I need other users to be able to see the task (a POP3 preview program), and take appropriate action.


  spikeychris 14:15 24 Sep 03


Go to C:\Documents and Settings\All Users\Application
Data\Microsoft\Crypto\RSA\S-1-5-18 and delete the files in there.
Scheduled Tasks will recreate the files needed.

Note: This folder is hidden by default. Go to Start/Run and type in:
control folders. View: Show hidden files and folders.

Also try running without a password:

For Pro: Start/Control Panel/Administrative Tools/Local Security
Policy/Local Policies/Security options. In the right hand pane (third down).

Accounts: Limit local account use of blank passwords to console logon only.
This is enabled by default, disable it.

For Home: Run Scheduled Task without a Password (Line 67)
click here

Scheduled Tasks - Auto Start (getting tasks to run when no one is
logged on). If you follow these steps, the shedlgu.txt file will be
replaced without any information other than system start-up information upon
the first boot.

Go to Start/Run/Msconfig. Click Selective Startup and uncheck Load System
Services, click ok. Reboot.

Upon reboot, click OK to the first Window that indicates that you have
selected "Selective Startup". When the System Configuration Utility
reappears, Check the Normal Startup Box.

Then go to Start/Search and type in: schedlgu.txt. When it appears, right
click on the file and delete it. Reboot.

You will now have a new Task Scheduler Log File. It can be checked by going
to Start/Search and typing in: schedlgu.txt. Appearing will be your new Task
Scheduler Log.

  Markdym 10:42 01 Oct 03

Hi SpikeyChris, thanks for answering.

I have tried your solution without success. When I logon as a different user the tasks are not visible. Also, when I logged back on as myself, none of my tasks run.

Also, I created a restore point - just in case, before I strated this. However, after determining that the solution did not work, I logged back on and discovered that System Restore cannot restore my old point. It was not listed. The only restore point I could access was a single 'automatic' system restore point.

I now have my my computer back to normal, but I don't recommend offering this solution to anyone else.

Thanks anyway


  spikeychris 11:19 01 Oct 03

Sorry if this caused you greif but it was a pasted post, I had not tried it. It came from the Kelly stable were someone matching your thread had the same problem.

  Markdym 12:31 01 Oct 03

Thanks for the info. I have also tried this on TechRepublic but each response said it could not be done. One respondent claimed that some of his clients running WinXP (SP1), cannot get scheduled tasks to run at all! So, I guess I should be grateful that I can run them on my machine! I have also tried Microsoft's KB, without success.

If I come across a solution I shall post it.

  Chegs ® 14:27 01 Oct 03

Bookmarked for reference.

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…