SB Live 5.1 Drivers

  Tazfan 21:55 04 Aug 03
Locked

Hi all.

Running XP. Done search on here, and have had no joy. Most point to the Creative site, and one or two others will not open for me.

Looking without success for the latest drivers for the above. I have tried navigating the Creative site with no success. When I find the right page, the site just hangs and will not allow me to download the driver. From what I can gather, the latest driver was released on 10/03/03. Does anybody know where I might get it from, apart from the Creative site?

As always. many thanks in advance fro your time and your help.

T:-)

  VoG II 22:04 04 Aug 03

Have you tried click here ?

  Geoff_T 22:11 04 Aug 03

You can also get your drivers from here.

click here

  Tazfan 00:39 05 Aug 03

Typically, as is usual for my luck, I have had no success finding the drivers yet. On the Creative site, I just end up with a blank page after I hit the "I agree" button, then nothing at all happens.

Geoff, with your link, I just get "page cannot be found".

Im having all sorts of sound related problems, including stuttering sound, and microphones refusing to work. The driver I have is pretty old (2001), so an update is well over due. Any other suggestions? Ive done a £Google", but end up with the same results, either page not found, or other problems.

Thanks for your continued help,

T:-)

  crx1600 00:54 05 Aug 03
  Tazfan 01:18 05 Aug 03

Thank you crx1600, but I get as far as "Connecting to the server...this make take a few seconds.
If something goes wrong, try clicking here", and thats it. If I click "here", I am just taken to a blank page.

I have disabled my firewall and AV software incase they were causing the problems, but no change. I even phoned a m8, and he cant get to anywhere for the driver either.

I am fast running out of patience now. Such a simple task and all!!

Cheers, T:-)

  crx1600 01:22 05 Aug 03

you must have an underlying problem, that needs addressing, as i tried the download before posting.

do you have any 'popup-stoppers' running?

  crx1600 01:25 05 Aug 03

PS, i could send you my backed up livedrvpack.exe via email, although its not the latest version, it is for XP.(24.7MB)

  Stuartli 08:51 05 Aug 03

The final Live 5.1 drivers were apparently issued in 2001 (there may be exceptions for XP); I have a backup of them and was also unable to find any later versions on the Creative website.

Mind you Creative's support is, at best, average and at worst useless - I know from reading the despairing comments on the forums hosted, ironically, by Creative itself, when seeking webcam updates, patches etc...:-)

  Bodi 10:08 05 Aug 03

I had all sorts of problems with the drivers on my 5.1 Platinum with "Live Drive" on Windows 98SE. Then I discovered that if you omitted the Dos drivers, and Creative Player, and all other add-ons that I didn't need - they actually worked without the Windows Protection Error coming up!

I am using the original drivers on XP and they all seem to be working OK.

Don't know whether this will be of any help - but from experience I've found that Creative drivers can be a real pain.

Bodi

  Stuartli 10:35 05 Aug 03

The following thread of mine about SoundBlaster cards and Win98SE shutdown problem (DOS driver the cause) may be of interest:

click here

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

The Pantone Colour of the Year 2017 is Green

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…