SATA RIAID alongside IDE RAID: is it posssible?

  mrdsgs 10:09 15 Jun 04
Locked

IDE RAID and SATA RAID ?
I have a Gigabyte GA7VAXP- A Ultra motherboard which has both IDE RAID and SATA RAID connectors. I have a RAID 0 array on the IDE RAID which has 2x40gb Maxtor ATA HDs. They are partitioned into 4 with C being boot partitition W2000, D being XP, E for Data and F for Backup. It is set up to dual boot.

I also have a PCI SCSI card witha 72gb drive attached for data and backup of the above.

I need more storage and want to add 2x80gb SATA drives as SATA RAID 0 in addition to the above. Can I do this?

I want to keep everything else as is.

I have enabled SATA in bios set SATA to RAID (rather than BASE). W2000 and XP then picked up the SATA RAID controller and I supplied the driver. All appears well in device manager.

However, when I boot up I have the option of entering IDE RAID to setup/change an array and also to enter SCSI bios, but no option to "push F4" to set up SATA RAID. Is this simply because I have not connected SATA drives yet or I have I missed something?

First boot device: Floppy
Second Boot Device: HDD 0

SATA/RAID/SCSI boot order in bios is set to RAID (if I change it to SATA I do get to SATA RAID bios options at boot up but IDE RAID is not visible while booting. As I need to boot from IDE RAID I cannot leave it on that setting) Should I set it to SATA to set up the SATA RAID array and then change it back to RAID? This is my intention I think !!!

Will it sort itself out when I get the drives (probably tomorrow) or am I expecting too much or missing something? Any comments or advice would be welcomed as ever

mrdsgs

  Chegs ® 13:38 15 Jun 04

Same mobo,with SATA RAID setup running XP Home.I have had to setup the SATA as "striped" as selecting "mirrored" produces a message about insufficient hdd's.My SATA system is a pain,it has to be on 24/7 or at least 20mins on BIOS screen to get a successful boot,trying to fire up from cold straight to XP produces "Incomplete RAID set" errors,and I have to repartition,reinstall everything again.I have tried the large HDD patch(slows down shutdown to give the cache chance to fully clear)different SATA drivers,and generally buggered about with just about every option suggested in google searches.I would expect yours to dredge up something that wasn't expected,so would highly recommend you have an image of your OS to speed up reinstalls(although mine often takes hours to reinstall the image,then fails in the last few percent)The SATA hdd's aren't noticably faster than my IDE systems,but it is a hell of a lot more problematical. ;-)

  mrdsgs 13:39 15 Jun 04

bump

  mrdsgs 13:41 15 Jun 04

thanks chegs, i will heed your words of caution

mrdsgs

  Chegs ® 14:10 15 Jun 04

Also,the presence of IDE hdd's slows down my SATA system,boot can take over ten minutes,after a few days of crawling along,it finally crashes and fails to reboot to XP as "system files missing/corrupted" If it was me,I would opt for either just SATA/IDE RAID,as mixing the two could be a recipe for disaster.

To answer your question,the SATA controller needs the physical SATA hdd's as well as enabled in BIOS,but I think you can only have IDE or SATA RAID,if enabling SATA "turns off" the IDE RAID.It might need the OS etc installing onto SATA to "detect" the IDE system,but as I only have 1 IDE and 2 SATA hdd's that refuse to play ball with a "proper" RAID setup,I am unable to find out for certain.

  mrdsgs 11:34 16 Jun 04

i will await delivery of sata drives then post back

if "dual raid" is not possible the obvious solution is to run both sata drives as "BASE" leaving the os on the ide raid.

surely that would work?

mrdsgs

  Chegs ® 15:24 16 Jun 04

I imagine that should work,but my experiments with IDE & SATA hdd's showed that simply enabling IDE in BIOS created a slowdown of the whole system leading to an unrepairable crash after three days.I occasionally had both IDE & SATA hdd's and no noticeable slowness without running a HDD test(but still ended up reinstalling over again as TempGenc was having a bustup with another prog and crashed the system)I haven't done any video editing for a while(due to the time taken to load the vid then start rendering,etc was often longer than I was getting between crashes)and as TempGenc hasn't been loaded I have had no bother with the system for a couple of months or more.(*Touches wood*) ;-)

  mrdsgs 19:01 16 Jun 04

Sorted!

I am pleased to say that it can be done, and has been done.

By temporarily changing boot order to sata first, the sata raid setup appears during bootup. Raid array can then be created.

Then change boot order back to ide raid first, reboot and then even though there is no longer any sign of sata during boot up, it obviously is picked up and the "unallocated" array is picked up in windows xp and w2000 as the os is on the ide raid.

then its just the usual partition and format.

thanks everyone for the above comments, especially chegs. 6 hours and all is well so far!

please mark as sorted.

mrdsgs

  SEASHANTY 19:06 16 Jun 04

Was wondering what you do when the PC's start smoking with all the heat generated by all these extra HDD's?

  Mister Splendid 20:05 16 Jun 04

It is yourself that must mark the post as sorted.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

Best Christmas Agency Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…