SATA Drive not being recognised.

  Sepulchre 01:03 02 Oct 03

I've just finished building my system which is an MSI K7N2 with a Maxtor Diamond Sata Drive, at XP install it wont recognise the SATA drive.

Can anyone offer any suggestions of whats wrong?

  tjg 00:03 09 Oct 03

Had similar problem.
When XP set-up runs, press F6 key. Insert floppy disk with sata/raid drivers when asked for.
XP should now see the drive & continue intalling.

This works for a new XP install.

Anyone know how to copy existing C: drive to new sata drive? (both NTFS)

Have tried Ghost v7 No Luck

Any advice/links appreciated


  Ironman556 00:18 09 Oct 03

Only thing I could add to TJG's comment is that you should be able to get the driver from your motherboard CD. I did.


Have you tried burning an backup to CD then restoring to the SATA drive? :- Never tried it myself, I just copy the files I want to 2nd partition/drive and format primary, them move them back when I'm all sorted with a fresh install.

  Ironman556 00:19 09 Oct 03

Sorry for the rubbish speeling... just typed this out and crashed, and had to re-type...

  Chegs ® 01:48 09 Oct 03

To install XP onto my SATA hdd,I had to set BIOS to First boot=scsi(I need to check their settings in BIOS as I cannot recall them all),then boot Setup XP,F6 to install SATA driver(only mine weren't XP certified) but still got Hal.dll missing corrupt,and config.sys errors.It took 6 weeks of crashing/missing/corrupt file messages before I finally admitted defeat and reinstalled an IDE hdd to carry my OS and the new SATA drives are simply used as large storage space(80Gb's of video files)I was just looking thru my previous postings on here as I had to ask howto get XP installed,only I cannot locate it.It might take a while,but try a search for SATA threads to,as I have seen several threads on them.

  Chegs ® 01:57 09 Oct 03

Also,none of my backup software works as booting into DOS loses the SATA driver.I tried Ghost/DriveImage 5/2002/7/TrueImage and several other types of backup software,and not one could "see" the SATA hdd's.I replaced my IDE hdd,and am able to use DI 2002 to create an image onto either SATA hdd,but haven't yet tried reinstalling from it(due to Error message HAL.DLL is missing/corrupt)right after creating image today.When my present Repair of XP goes pear-shaped again(which it now does weekly instead of hourly)I will try the backup image before the Repair option.

  Sepulchre 09:12 09 Oct 03

Thanks for all the responses.

The problem I was having was during XP setup the F6 option was being ignored which was preventing me from loading the drivers.

I've since bought an 80Gb IDE onto which I installed XP and my rubbish, XP helpfully recognised the SATA drive at this point and installed the drivers for me. I then ghosted the install to the sata drive, changed the bios boot order, and now all is well :)

This worked for me, but I see from above ghosting doesn't work for everyone.

I think Chegs's resolution would have worked, I stupidly didn't link SCSI and SATA drives as being seen as the same thing in the bios. Maybe If I'd done this it would have worked OK.

This thread is now locked and can not be replied to.

How to watch Windows Event live stream, live blog | Microsoft event live stream: Watch Microsoft…

1995-2015: How technology has changed the world in 20 years

This amazing app turns your iPad Pro into a Cintiq

iPhone 7 Plus review: A superb big-screen phablet, but the price tag's enormous | iPhone 7 Plus…