Samsung S2 USB 2.0 1TB Ultraslim Portable Hard Drive

  exdragon 06 Nov 12
Locked
Answered

Hi - can anyone sort out what I'm doing wrong with this, please? I bought it on the strength of reviews on Amazon, and wish to keep my Lightroom catalogue on it.

All of a sudden, it says it needs formatting (it's pre-formatted NTFS),and when I use it with Lightroom, this program stops working and closes down, whereas previously it was working ok. I keep getting a screen headed Samsung Drive Manager popping up, and on a random basis, it says it's installing the driver software.

I have a couple of other external drives and simply plugged them in and used them, so I'm obviously doing something wrong. I can't find anything on the Samsung website.

Any ideas, chaps?

  Fruit Bat /\0/\ 06 Nov 12

yes Norton should be giving you ample protection so probably just a windows glitch which sfc should cure.

  exdragon 06 Nov 12

Fruit Bat /\0/\ - sorry, I don't understand - where does Norton protection come into it??

  lotvic 06 Nov 12

I believe Fruit Bat /\0/\'s post should have been on nissanalmera's thread not on this one.

Samsung Drive Manager, I think I remember another thread with the same problem, I'll have a search and see if I can find it. I think solution was something along the lines of stopping Samsung Drive Manager from automatically starting.

  exdragon 06 Nov 12

Thanks, lotvic - I feared I was getting a little more confused than usual!

  lotvic 06 Nov 12

Seagate have taken over the support of Samsung ext hard drives. This explains about the Samsung Drive Manager http://knowledge.seagate.com/articles/en_US/FAQ/221683en

  exdragon 06 Nov 12

Many thanks - I'll have a look after my pre-prandial G&T!

  Fruit Bat /\0/\ 06 Nov 12

How did that post get in here? This is first time I've looked in this thread.

My apologies to all concerned.

I bought a lacie drive that gave me similar problems and had to disable the inbuilt programs to get it to work properly on my XP system.

  lotvic 06 Nov 12

Fruit Bat /\0/\, I sometimes get the wrong thread heading on tab when I open a thread.. By that I mean the title of the thread doesn't match the title on tab in Firefox. Next time it does it I'm going to post on the thread and see which one it appears in ;)

  exdragon 07 Nov 12
Answer

Problem solved: a reformat got seems to have worked.

  exdragon 07 Nov 12

Hmm, ignore the'got'

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

IKinema aims to banish droopy shoulders and wonky spines in animated CG characters

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message