RichEd20.dll error message

  roger 10:54 06 Oct 06
Locked

My laptop with XPhome and Office 2007 B2 was running fine until recently it started slowing down after having been in use. Spysweeper and ASO are installed so I did full scans and got rid of reported spyware. I also did a full defrag with Perfectdisk but none of this seemed to help. I then started to get this error message.

"Explorer.exe - Bad Image. The application or dll c:\windows\System32\RichEd20.dll is not a vaild windows image. Please check this against your installation diskette"

Sometimes the title of message refers to Webroot or other progs.

I have done two system restores going back a couple of weeks or so to when I reformatted the HD and reloaded all progs (so the machine should be clean) but this done get rid of the messages.

It seems I might have no choice but to go through the full format process and reload Windows, Office etc., etc. again which I do not fancy, unless anyone has any suggestions!

Help!

Thanks

Roger

  Diodorus Siculus 11:05 06 Oct 06

Do you have XP CD?

Try the system file checker

start

run

sfc /scannow

  Pineman100 11:06 06 Oct 06

I have no experience of it, but this might help: click here

  roger 09:57 09 Oct 06

Thanks to Diodorus & Pineman for the suggestions. Unfortunately neither seemd to solve the dilemma so I bit the bullet on Friday evening and went for a full format and re-load. Boring but it worked and the machine is now whizzing (well almost) along.

Thanks again.

Roger

This thread is now locked and can not be replied to.

Sony Xperia XZ Premium review: Hands-on with the new 4K HDR phone with Motion Eye camera and Snapdr5…

1995-2015: How technology has changed the world in 20 years

Best laptop for design and art 2017: we test Apple, Dell, HP, Lenovo and Microsoft's best models…

CarPlay tips & troubleshooting guide: CarPlay tips & troubleshooting guide: Get the most from…