Repair to master boot record?

  Hedontownee 19:12 28 Jul 04
Locked

Can you help please/
I have 2 HD ..C drive and D drive
I have XP Pro on C drive and I had Win ME on the D drive
I re-formatted D drive to get rid of ME but I forgot about the MBR that allows you to select a version of Windows
How can I repair the MBR so that the system boots to XP Pro on C drive without showing the bootup menu??

  woodchip 19:29 28 Jul 04

start with a Win98se OEM floppy disc from click here

Put a floppy disc in comp, and double click the above file to create a Win98se floppy start disc.

Start with the Disc in comp, if it does not reccognise the floppy, you will have to go into BIOS by pressing Del key or some other to get into BIOS. Set the Computer to Boot from first device Floppy disc.

After starting with floppy, let it load to A:\> then type FDISK /MBR C: press enter

I am not too sure but I do not think that you need to mess around with the mbr although Woodchips advice is 100%.

Locate the Boot.ini file on the C drive and edit the time to zero should do the trick?

  temp003 03:34 29 Jul 04

If you used third party boot mananger software such as Bootmagic to create the dual boot, woodchip's method should do the trick.

If you used XP's native dual boot function to create the dual boot, you'll need to edit the c:\boot.ini file. Post back if necessary.

  Hedontownee 05:44 29 Jul 04

Thanks one and all
To Woodchip: Carried out your solution but it didnt like the syntax you suggested..ie FDISK/MBR C:
-----------
To Whisperer
Boot.ini shown in Msconfig..could only reduce time out to 3 seconds!!!!
Problem still there I'm afraid ..any further comments would be apprciated...

  Hedontownee 05:47 29 Jul 04

To temp003
Can only see boot .ini using msconfig and cannot seem to remove reference to second version of windows

  Chegs ® 05:55 29 Jul 04

You should retry Woodchips method but make sure you put a space between fdisk and /mbr

  Rigga 08:34 29 Jul 04

Right click My Computer on the desktop.
Choose Properties.
In the Advanced Tab.
In the Startup and Recovery section, click Settings.

Uncheck the box next to "Time to display list of Operating Systems".

Reboot.

If this works.

Go back through the steps as shown above, but instead of unticking the checkbox, which you've already done. Click the Edit button, to manually edit the boot.ini file. After you've backed it up of course. The just delete the line that has the unused OS on it.

Reboot.

Hey presto.
R.

  temp003 08:41 29 Jul 04

You haven't said how your dual boot was created, so I'm not sure whether you need to edit boot.ini.

But since you refer to "second version of Windows" in boot.ini itself in msconfig, it's possible you need to edit boot.ini.

Try the fdisk /mbr c: method again with proper spaces. If it doesn't work, then try the following.

In XP, click Start, Run, type c:\boot.ini and press Enter. This opens boot.ini in Notepad. Insert a floppy and in Notepad, click File, Save As, and save the file to Drive A. This backs up the file. You could edit boot.ini here, but
since I don't know what your current default OS is, it is safer to take the following route.

Remove floppy and exit Notepad.

Right click My Computer, select Properties, Advanced tab, Startup and Recovery, Settings.

Under System Startup, make sure that the "default operating system" is XP, not ME. If it is already XP, go to the next paragraph. If it is ME, click the down arrow and select XP from the list, then click OK, and OK again to exit System Properties.

Back in Startup and Recovery, Settings, you have 2 options.

One is as Whisperer suggests, change the time from 30 to zero seconds for the box "Display list of OS for ..." how many seconds. Click OK, OK. Restart.

This hides the boot menu. Very simple, but the reference to ME is still there in boot.ini. Doesn't really matter though.

The second way, if you want to be neat, is to leave the time as it is, but edit out the reference to ME. In Startup and Recovery Settings, click Edit. This opens boot.ini in Notepad.

The only change you need to make is: under the section [operating systems], delete the line that says something like:

C:\="Microsoft Windows ME"

Just delete that line, then click File, Save. Exit Notepad. Click OK, OK to exit System Properties. Restart.

  temp003 08:42 29 Jul 04

I'm too slow.

but thorough m8. You might be able to help out in the following thread entitled:

Save As in Excel 97

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

iPhone 9 and beyond: 32 amazing future smartphone developments - graphene, supercapacitor…