Remove items from "safely remove hardware" list.

  Dorsai 24 Sep 12
Locked

I know this can be done, because I did it, I just do not remember how .

My PC shows the "safely remove hardware" icon all the time, offering me the option to "safely" remove the SATA HDD that has my operating system on it, Windows XP.

While I fully understand that a SATA HDD can be removed in such a manner, I would never want to actually do so. When I first built this PC I somehow managed to persuade it that the SATA HDD's in it were "fixed" rather than "hot swappable." As a result the icon only came up when I had an item that needed "shutting down" was plugged in, such as a USB memory stick. Following a minor crash I had to delete and re-set up the Administrator account, resulting in the loss of all my "customizations" to XP, Passwords I remember, Firefox Add-ons I can re-install, but I can't remember how persuaded XP that the hard drive it is on in not removable. Thanks in advance for the help.

  LanceAlot 24 Sep 12

Try fiddling around in the bios.

  woodchip 24 Sep 12

Have you looked in Device Manager? Right click My Computer/Hardware/Device Manager then check properties of the drive. You may be able to change them in there

  lotvic 24 Sep 12

Is there anything you can alter in: rightclick My computer | rightclick Local Disk (C:) | Properties | Hardware Tab | highlight the Drive and click on Properties | Policies tab

I had a look at mine and I can't alter it as it is greyed out, but mine is a fixed drive so doesn't come up in the Safely Remove list.

My other usb drives are not greyed out and I can alter setting in Policies.

  lotvic 24 Sep 12

Oh, woodchip's way of getting to same properties policies window is quicker...

  Dorsai 30 Sep 12

Sadly it is not as simple as clicking on a tick box somewhere to say "non removable".

I am sure I had to go into Regedit, and change a "true" to a "false" (or the like.) But it was so long ago.

  Forum Editor 30 Sep 12

It sounds to me as if your SATA controller is set to AHCI mode in the Bios. Go into your Bios and take it out of this mode - that should do the trick.

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

Microsoft claims its new VR lens system is better than Oculus Rift's

Apple Music preview: Why Spotify should be scared of Apple's impressive new music-streaming service

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message