realtec ethernet adapters compatibility with sweex

  papavasi 17:47 31 Jul 07
Locked

hi to everybody,
i'm entirely new to this forum and that's my first post.
my problem is that i have bought the sweex mo250 adsl/modem router and i want to plug 4 pc's on it.
the first two pc's have the realtec 8139 pci fast ethernet adapter and they connect properly via the router to the internet.
the other 2 pc's have another model of realtec the rlt pci 8169/81100 family gigabit ethernet adapter and they appear the message : "network cable unplugged". By using control panel i can see that the pci adapters are properly installed without having problems or conflicts, so i wonder wheather there is incompatibillity between the simultaneus use of these two models with the specific router. or should i assume that they are dammaged? i have not made any experiments by using other pci ethernet cards.
all pc's use the win xp pro v2002 os.
i would really appreciate any help and oppinions.
thanx
Chris

  ambra4 19:37 31 Jul 07

Check the Realtec 8169/81100 Ethernet adapter is not set to run at Auto or 1000Mbps as router will only run 10/100Mbps

If not sure if on how to check the Lan card setup do the following

Start-Network Connection-Local Area Connection -Properties

At the top of display the type of Lan card will be displayed-click Configure- Click-Advanced

In the box listed below click Connection Type – In the value box change the setting to100 base Tx Full Duplex.

  papavasi 13:18 01 Aug 07

hi ambra
the problem stil remains and the message i receive is the same :"network cable unplugged".
some other parametres of the realtec 8169/81100 advanced properties are the following :
-flow control
- jumbo frame
-link speed/duplex mode (which i allready changed)
-network adress
-offload checksum (which i allready changed)
- offload TCP largesend

i wonder if i should change some of these parameters or should i suppose that the ON BOARD chip is dammaged.

any other opinions would be appreciated.
thanx a lot in advance

  ambra4 17:47 01 Aug 07

Go this site and download the following software under the Windows heading half way down the page

RTL8169

Windows Diagnostic Program (support Win98SE/WinME/Win2K/WinXP)

Auto installation program (support WinXP 64/Win98SE/WinME/Win2K/WinXP ver.673

Run the Diagnostic first an see if that solve your problems

It seems that this Lan card is used on main network servers.

Base on the information listed, don’t see why it should not work on a normal desktop computer

click here

  papavasi 19:22 08 Aug 07

been a little late, had to travel for a few days...
the solutions you gave me were absolutely correct in my opinion but the problem remained, so, having nothing else to do i tried a Realtec 8139 10/100 PCI ethernet adapter (similar to the adapter the other two pc's on my network have) it worked!
thanx for your interest that shows the forum is active and high-level in technical matters

  ambra4 21:24 08 Aug 07

Glad to here that you up and running

I have to ask one of our server networks expert about this Lan card why it would not work on a normal desktop if get any answers will get back to you

Enjoy for now

  ambra4 21:26 08 Aug 07

Tick the solved box

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Best Design, Illustration, Animation and VFX Awards of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced