Ramdisk switches off System Restore

  GrahamP 12:10 19 Apr 04

I used click here to install a 32M Ramdisk and was very impressed by the results until I found out my System Restore points were disappearing.

From errors recorded in Event Viewer and posts elsewhere, I found System Restore was monitoring system datasets on Ramdisk even though it does not appear in the list of disks monitored. (System/Properties/System Restore)

When any monitored datasets changed or were deleted it would appear to invoke a recovery process which would look for the minimum (200M) space on the volume, which of course isn't available. At this point System Restore would cease functionning, though this would not be indicated in System Properties, and all Restore Points would disappear.

I thought I had a workaround. The dataset most frequently causing the problem was Recycle. Turning off Recycle for Ramdisk seemed to solve the problem and I'm sure this was preserved over a restart at least once. However it's happened again and I find this time Recycle is restored for Ramdisk every time I restart.

How can I switch System Restore off for Ramdisk and/or how can I retain the No Recycle setting for it over a restart?


  VoG II 13:07 19 Apr 04
  GrahamP 15:27 19 Apr 04

Not sure if your post is meant to be ironic Vog since it quotes the same link I had at the top of mine, but it doesn't seem to cover this unless I've missed something.

However I've come up with this solution which has survived a restart. To get round the fact that Ramdisk doesn't appear in the System Restore tab of System properties I've added a value in the registry to cause it to ignore anything on Ramdisk as follows.


Add new multistring value "Ramdisk". Give it a value of "B:\*.*". If this proves a false dawn I'll post back and if I've reinvented a perfectly good wheel, then sorry for being obtuse.

  VoG II 15:31 19 Apr 04

Not ironic at all. If you persevere to around page 3 the System Restore "feature" starts to be discussed. There were several other threads related to this but that's the only one I found by doing a quick search.

  GrahamP 16:00 19 Apr 04

I think it's attention deficit syndrome.

I'd tried "disable, reboot, enable" several times and the problem always came back. If the FilesNotToBackup continues working I'll stick with it.

  GrahamP 23:16 16 May 04

The "*.*" didn't work and I've now copied the entry for temp files:

FilesNotToBackup B:\* /s

I haven't a clue what the /s means but it's been working now since the 5th of May.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…