Radeon 9600/9800 problem.

  mike350 11:50 08 May 05
Locked

I have an ATI Radeon 9600XT with 256mb RAM, which works fine, except that "The Chronicles of Riddick-Escape from Butchers Bay" will not play. I get a message saying adaptor capabilities insufficient to run game.
I also have a Peak Radeon 9800SE also with 256mb RAM. When it is installed, my PC boots up to just before XP welcome screen, then monitor goes to sleep, but hard drive appears to continue working. I've tried starting up in safe mode, to no avail. As both cards use the same drivers, this is a mystery to me. PC details are PC Chips Mobo, with Via K8T800 chipset Family/8237, AMD 64/3000 and 768mb of RAM
Any ideas??

  Totally-braindead 12:17 08 May 05

I suggest that you look at the game website click here and see if theres a fix there, I had a quick look in the Community pages and did see advice from their Moderator that said something about you need SP1 installed.

  Klof Ron 13:40 08 May 05

Do you have the latest drivers installed click here. I also have a Radeon 9800 XT which blacks out on boot up. I found the culprit was the BIOS setting. If I have "Performance Defaults "loaded it blacks out, but if I revert to "Load Optimised Defaults it runs OK. Also on the ATI website it recommends SP 2 Should be installed.

  mike350 14:49 08 May 05

I have the latest Via drivers installed, and only today installed most recent Catalyst for ATI. Set BIOS to Load Optimised defaults, and on changing to 9800SE, exactly the same problem. No signal comes up on monitor. And it goes to sleep.

  rubella 16:52 08 May 05

mike350

What happens if you whack in the 9800SE, run the Catalyst™ Uninstaller - click here -, and feed it click here ?

  mike350 17:06 08 May 05

rubella,
Thanks for your reply.
How do I run the Catalyst Uninstaller with the 9800 in, when it won't let me into windows? Is it maybe a XP problem?

  rubella 20:56 08 May 05

mike350

You don’t, that was me being dim. I think I got a bit carried away because the bonus you might get from the 9800se with Omegas exceeds what you could get from the 9600XT, and that I’ve run three 9800se[s] faultlessly with them.

Right, as the 9600XT seems to hold up for longer you could try the same procedure with that card in.

It might be a problem with XP we are missing, but I think completely removing all things ATI with that tool and reinstalling has to be the best starting point. Should that fail, next in line for my suspicion would be the chipset drivers, but you’ve already thought of that.

What about power supply to the card?

  mike350 21:13 08 May 05

rubella.
I had just finished following your advice and having a spot of dinner when comms came through from the forum. I pleased to say that all is singing and dancing now. I ran the uninstaller with the 9600 in, shut down, changed cards and hey presto!! I've installed Omega drivers as per your link. Benchmark 2001 has gone from 8475 with the 9600 to 10871 with 9800. However Riddick still won't play. I'm uninstalling and reloading.
Thanks a lot for your help rubella. And everybody else who took time and trouble. Great stuff!!

  rubella 19:42 09 May 05

mike350

Mah pleasure amigo.

I suspect the remainder of your problem may well be something to do with Riddick and SP1, as above.

  mike350 19:58 09 May 05

Rubella, I uninstalled, reinstalled, no probs, all Ok. I have SP2 no knew it shouldn't be that. Once again thanks for time and effort.

This thread is now locked and can not be replied to.

Xiaomi Mi5s review: The Xiaomi flagship that could replace your Samsung, LG, HTC or Apple phone

1995-2015: How technology has changed the world in 20 years

Mental Canvas is a brand new drawing app that's quite unlike any other

New MacBook Pro 2016 review | MacBook Pro with Touch Bar review: Apple's super-expensive new…