R300 USB Printer not working / win 2000

  sparky11 18:29 31 Dec 04
Locked

Epson HELP line failed to solve this problem

I,m running win2000 SP4 on a AMD Athlon 2600+ on a Asus motherboard A7V8X with Via400 chipset.
Epson driver intsallation cannot find the printer on the usb port and defaults to LPT1 and in device manager it shows up as a yellow ? ,if I reinstall the driver through device manager it appears in printers as a usb2.0 MFP(Hi-Speed) but when I go into properties it says No drivers installed for this device.

  €dstowe 18:47 31 Dec 04

First of all try removing all traces of printer software from the machine (drivers, monitors etc).

Then install the software EXACTLY TO THE LETTER as per the instructions. Do not connect the printer until you are told to in the installation procedure and do not proceed further until the printer has been connected at this point.

Printers as VERY finicky about correct installation and even seemingly trivial alterations to procedure can make the difference between a successful install or a total disaster.

May not work but, there's nothing to lose by trying this.

  Newuser4427 20:07 31 Dec 04

Amen to 1st advice.
Only consolation while Epson ARE very finicky, HP are TEN times worse.
HP have had to issue a freebee that doubly checks if all their drivers etc actuially have been uninstalled before you start again.
Best of luck, just be very patient because when you do get it working you definitely will like it.
All the best to one & all, I'm off back to the wine.....

  Cook2 20:24 31 Dec 04

I also have an R300 and just did a quick check with the printer connected and switched on.

In Device Manager - Disk Drives, it shows Epson Stylus Storage USB Device. Nothing else shows Epson.

Go to Control Panel - Printers and Faxes and right click and delete any icon/ showing Epson.

Go to Device Manager and right click and uninstall any devices with a ? or ! next to it.

Turn off your printer and disconnect the USB cable from your computer.

Reboot. Insert Epson Installation CD and follow instructions. DO NOT connect or switch printer on until requested to do so.

Happy New Year.

  Technotiger 23:43 31 Dec 04

Very interesting read - my next purchase!!
Happy New Year to All :-))......hic!

  rickf 10:26 01 Jan 05

I have this printer but using XP. Installs w/o a hitch and its a wonderful printer although a bit slow. I made sure I uninstalled all previous printer drivers before putting in the new one and follow instructions to the T. Perhaps its time to uninstall and start again from scratch.

  sparky11 15:06 01 Jan 05

Thank you all and Happy New Year.
I have just tried uninstalling all Epson software and all peinter drivers again, but when I re-installed the Epson software it failed to find the printer as before but it did show up as a usb2.0 MFP(Hi-Speed) under printers in device manager.

Cook2
I find it rather odd that a printer shows up as a Storage USB Device is that on Win 2000 ?

  rickf 15:17 01 Jan 05

Did you disable antivirus software before installing? You have too for this printer.This may be a silly question but a mistake easily made.

  sparky11 15:45 01 Jan 05

Yes I disabled antivirus / firewall and every thing else I could find.

  rickf 16:50 01 Jan 05

Strange problem you have. I am baffled. Just a thought! Are you plugging it via a hub? Not that this normally should cause probs. I am very curious about this prob as I had no difficulty at all installing it.

  rickf 17:09 01 Jan 05

Another thought, could the installation dics be faulty. Worth a try getting Epson to send you another or is it possible to download drivers from the Epson website. Worth a try I think.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…