Goldfox 19:47 21 Sep 05

20/20 is an unknown quantity at this point

Exclamation power supply/connection
remember i posted a topic a couple of weeks ago, about my computer having trouble turning on?

well today it finally broke.

the problem was that i couldn't turn the computer on straight after turning it on at the plugs. i had to wait for some reason...

the time i'd have to leave the plugs on before the PC would allow me to turn it on had been going up from 5 mins all the way to 10 hours, and today it didn't turn on at all, it's been almost 20 hours now.

i've tried reseting the RAM, HD, GFX Card, everything. I've tried disconnecting and reconnecting the connection from power button to mobo, the light on the mobo is on, so there's power running through it, so could it be a faulty power button, the wires are fecked or something?

help would be greatly appreciated.

( i'm on a laptop atm, in case you're wondering )


  woodchip 19:57 21 Sep 05

Did you replace the PSU?

  Goldfox 20:01 21 Sep 05


  woodchip 20:02 21 Sep 05

Then I suggest you do

  DieSse 21:37 21 Sep 05

And if it's not the psu, then it's probably the motherboard. Im my experience the psu is only marginally more likely than the motherboard.

  woodchip 22:18 21 Sep 05

I would agree on the above

  Taff36 22:48 21 Sep 05

click here deja vu?


Weird is what I would call it.

With mine, when the PC swithces itself off, the power light stays illuminated on the front of the PC. To clear this I either have to unplug the PC or hold the power button in for 5+ seconds. I can then power it back on again.

I guess the answer is to try a new power supply then.

This thread is now locked and can not be replied to.

Microsoft Surface Studio PC release date, pricing, design, features and spec: Microsoft showcases…

1995-2015: How technology has changed the world in 20 years

This amazing app turns your iPad Pro into a Cintiq

Apple Q4 2016 financial results | Apple earnings report: iPhone, iPad and Mac sales down, profits d6…