Proview 17" TFT + Mains Hum!

  midiking 21:21 06 Mar 03
Locked

Hi Folks, I have just changed over to TFT monitor which gives good results, except that I have had to stop using my Labtec satellite speakers due to MAINS HUMMMM! I feel sure this is due to an EARTH LOOP. But can't find how to get into the Bass unit to fit filters to the audio cable screens. Has anyone else had this sort of problem?

The Monitors built in speakers are fine but not music quality. Any help would be greatly appreciated.

Proview have been very good, and sent me a replacement power adapter to try but the result is exactly the same.

  Pesala 10:48 09 Mar 03

Sorry, I canot help much, but this article might tell you if it is an earth loop.

click here

  midiking 15:07 09 Mar 03

Thanks for your help, and I have removed the hum but not by a method that I would advocate for anyone else to try. I have disconnected the earth wire in the mains plug to the Labtec Base unit!.
I tried to get in touch with Labtec but they don't appear to have an e'mail address for customer support.

I had already checked for ground connections between mains earth and audio feed connectors and didn't find any, then purely by chance decided to see if anything showed up between the mains earth and bass speaker input and much to my surprise found that one side of the input plug was a dead short to mains earth.

I must get in touch with them for an explanation.
Tnx,
Keith

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…