Problems using USB devices through hub

I have a Toshiba Satellite A30-514 with a powered USB 2.0 hub attached. Into this is plugged a USB satellite receiver (for broadband), a USB bluetooth adapter and an HP PSC 1350 printer. The first two devices work fine but the printer isn't recognised properly.

If I plug the printer straight into the USB socket of the laptop it works fine. These 3 devices have to go through hub(s). Would running another powered hub off of the first hub cure the problem?

In the device manager, instead of showing all the HP devices it just has USB Composite Device in the USB Controllers section. This has an orange exclamation mark next to it.

If I boot up the laptop with all 3 devices plugged into the hub and switched on, the printer is detected okay but the Bluetooth Radio devices have an orange exclamation mark instead. I need the bluetooth device to attach a mobile phone to the laptop.

From left to right, looking at the front of the hub, the devices are 1) satellite receiver, 2) printer, 3) Bluetooth.

I hope this is clear. Any help / advice would be greatfully received.

  Forum Editor 19:17 30 Dec 05

it looks as though the hub isn't providing enough power for all three devices at once.

How many ports are there on the hub?

  woodchip 19:18 30 Dec 05

You have too much drain on the Mains hub adapter. Try any two of the above or one at a time to confirm

The hub has 4 ports.

The satellite receiver and the printer both have their own power supplies so shouldn't be drawing much from the hub. The bluetooth adapter is very small and low powered.

woodchip. Everything is fine with the satellite and the bluetooth attached. If I then plug in the printer I just get the Composite Device in the USB Controllers section with the exclamation mark.

As I said above, if I boot up with all 3 switched on, in the order given, the first two are picked up okay (satellite and printer) but the bluetooth device has the exclamation mark.

Could this be some sort of conflict? I thought USB was supposed to stop all that.

I have checked the Toshiba web site and there is nothing similar to this listed. There are no patches or downloads available. I can only assume that the problem lays within the hub itself or the way that it communicates with the laptop.

There was a similar entry to this a few months ago. click here

  woodchip 20:03 30 Dec 05

The yellow mark means the Driver is not loaded for the Hardware. Try loading it from the disc you got, there should be a setup file on it

  jack 20:16 30 Dec 05

See the latest on this link you star on it
click here

Also - dont be so busy - it a device is not in use unplug it.
Think of the bandwith a printer needs to get a data stream from the spooler - it is a wonder printers work at all serial wise.

woodchip. Yes I have tried that. All it says is that the Composite Device Cannot Start (error code 10 I think).

jack. the link you gave is the same one that I pointed to. In response to your other point, I need to be able to use all 3 devices at the same time. I use the satellite modem and the bluetooth adapter (with a GPRS mobile) to get onto the internet and then when I find something I want to keep a record of I need the printer.

  jack 08:41 31 Dec 05

Yers I see , but what about reorganizing your work style?
You could for example to all the work. save it.
Then plug in the printer and have as print session whjile you relax with a beverage of your choice.


The problem has been identified, all you have to do is reorganize your self to get over it.

Anybody on the day-shift got any ideas?

Yes, but Jack, the point is that I should be able to have the 3 devices attached and usable at the same time, and it's what I need. You try telling kids that they can't print something when online and how to go about getting round it.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac