Problems With Upgrade

  ZeroBreakerS 19 Jun 11
Locked

Hi, Recently, I upgraded my motherboard, RAM, CPU and Graphics card in my ageing emachines E4040 PC. I bought an ASRock N68C-S UCC Motherboard, some Crucial DDR3 RAM, an AMD Athlon II X3 450 and a Saphire Radeon 5670. I am new to builds, but certainly not to theory and software, so I figured everything would go without a hitch, but when i was building, i saw that my 300w power supply had a 20 pin connector and my motherboard had a 24 pin connector, and connected it without worrying. i checked all the cables were in before booting, but no image came up on the monitor. thinking it may have been a graphics fault, i took out the graphics card and used the internal graphics. this too failed to show an image on the screen. is it the motherboard, or the PSU? i would like some help please.

  Fruit Bat /\0/\ 19 Jun 11

Correct CPU for motherboard? AM3 CPU

Motherboard review "Even though this motherboard supports DDR3 memories, it isn’t a socket AM3 motherboard, but a socket AM2+ one. The difference between the two is the presence of a separate voltage line for the CPU embedded memory controller on socket AM3 models, a feature not available on this motherboard."

  chub_tor 19 Jun 11

CPU Support List for your motherboard shows that your processor is supported. It looks as if the board has both DDR3 and DDR2 slots, are you sure that they are in the correct place and correctly seated? You cannot mix them. There is a 24pin power connector and a separate 4pin conncector, are you sure that the 4 pin one is connected?

  ICF 19 Jun 11

Why don't you buy a []20 to 24 pin adapter1

  ICF 19 Jun 11
  ZeroBreakerS 19 Jun 11

The thing is, in my motherboard manual it states it can accept a 20 pin connector, and the problem persists with both integrated graphics and graphics powered by the PCI-E slot. I have double and Triple checked the wires are all plugged in correctly, the RAM is correctly configured and the only abnormality in my system is an IDE to SATA motherboard connector, which is attached to my DVD Drive.

I would really appreciate any suggestions, should i replace the motherboard? or is the PSU's fault? Or is it something i haven't thought of?

  ICF 19 Jun 11

Are the integrated graphics turn on in the bios?

  ZeroBreakerS 19 Jun 11

Can't access the BIOS, as nothing show up. the fans spin, the Power LED show, and thats about all.

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

Encore creates eerie effects for Spielberg's new TV show The Whispers

How to set up Apple Music & make sure you don't get charged: Get Apple Music for free

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message