Problems with Sky Fibre broadband on PC

  Paulivo 13:20 PM 14 Mar 13
Locked

Hi, I have recently had problems with slow broadband speeds on my PC. I appear to be getting upto 2mbps when I should be getting close to 40mb. I have been in contact with Sky and they are now sending me a new router, but I now think its not a router problem because I put on my Sony Blu ray player which is connected to the router and loaded up a movie in crackle and its showing that im getting 28mbps & the Xbox 360 doesnt appear to be lagging with any speed issues.I have scanned PC with Malwarebytes Anti-Malware & Spybot - Search & Destroy and a virus scan with Avast which bring up nothing.Also upto a week ago i was using Microsoft security essentials but during a scan it stopped working and kept switching off. I am using Windows 8 pro.

  Paulivo 14:45 PM 14 Mar 13

Right i have now tried Microsoft defender offline and still no sign of anything wrong. Also I have a dual boot system so I just booted in Win 7 and launched the internet and got 17mbps off the wifi dongle. Relaunched Win 8 and back to 2mbps so it appears to be a software related problem. any help will really be appreciated

  difarn 17:49 PM 14 Mar 13

First of all are all of your drivers up to date, particularly the network adapter? Do you have the same problem when you are connected by ethernet.

I came across these two solutions on another forum:

Solution 1

  1. Open Network Sharing Center
  2. Click Change Adapter Settings 3 Right click on WiFi and choose properties 4 Click Configure 5 Choose Advanced 6 From the list below choose minimum power consumption and change value to disable

7 Click Ok.

Solution 2

  1. Open Network Sharing Center
  2. Click Change Adapter Settings 3 Right click on WiFi and choose properties 4 Click Configure 5 Choose Advanced 6 On "Roaming Sensitivity" change the value to Disable 7 On the "Power Management" tab, deselect "Allow the computer to turn off this device to save power"
  Paulivo 18:22 PM 14 Mar 13

Thanks for answering. On solution 1 there doesnt appear to be a minimum power consumption option. only carrier detect,country region 11a, country region 11g IEEE802.11h,Radio On/off,Smart scan and on 2 no roaming sensitivity option but in power management ive deselected item but its made no difference 1.8256 mbps

  Paulivo 18:25 PM 14 Mar 13

Sorry forgot to answer Yes all network drivers are up to date And yes both ethernet & wifi are both giving me up to 2mbps

  difarn 06:55 AM 15 Mar 13

Perhaps you could have a look through some of these suggestions.

Advertisement

This thread is now locked and can not be replied to.

Sony Xperia Z5 review: Hands-on with the phone which the Z3+ should have been

1995-2015: How technology has changed the world in 20 years

How to choose a photographer

iPhone 6S preview: What to expect from Apple's next iPhone