Problems sharing internet access XP - Vista

  metafb 19:22 21 Apr 07
Locked

Hi,

I'm desperate now, please help!

I've got 2 pc's. One is running XP and is connected to the internet via a cable modem. I've just added the second pc, which is running Vista and connected them with a cross-over cable. File sharing etc is working fine and both machines can see each other on the network. The problem is, Vista machine can't access the internet.

I'm not sure where to start really, I've tried playing with TCP/IP settings, firewall settings and opening ports... I've set up a home network sharing the internet connection. It relly feels like i've done everything right. I've run out of ideas. Anyone know what I've missed?

  airat 19:52 21 Apr 07

I have the same problem

  rdave13 23:25 21 Apr 07

Don't know if this helps but from PCA mag,issue 143. Although both pc's seem to "find" each other here there is no connection to net on one. So to quote the mag-
"Vista and XP PC'S that are running on the same network may not be able to find each other, as Vista's default workgroup name is "Workgroup" and XP's name is "Mshome". To rename an XP workgroup, right-click on My Computer, select properties, computer name, change, and type Workgroup under Workgroup near the bottom of the screen. Click on ok twice to save the changes. Worth a try..

  irishrapter 23:35 21 Apr 07

I take it that you have ICS enabled on the XP computer?

Have you set your IP addresses on both computers manually?

On the Vista computer open a command prompt and type "ipconfig"
See if you have a default gateway address which should be the same IP address as the XP computer.

  metafb 00:13 22 Apr 07

Done all of the above. I have actually done a fair bit of research today and tried the usual fixes. Changing the network settings has meant file sharing is possible but the vista machine still cannot see the internet.

I was wondering if it was firewall or something, but I've tried opening ports and even taking down my firewall completely and no change. It's like Vista just refuses to see the internet through another OS.

A half decent suggestion was using vista as the master and xp as the slave... but good ol' microsoft don't have vista drivers for my cable modem, so that's not possible.

Been trying to get this working for 14 hours so far. Not a happy bunny.

  irishrapter 02:46 22 Apr 07

Could be a DNS problem, check your DNS settings by doing an "ipconfig /all" in a command prompt.

Or just try a direct IP connection to google by clicking the following IP address 64.233.167.99

  metafb 12:40 22 Apr 07

hmmm well.....

this is now resolved, but neither I or my girlfriend can figure out how/why. Last night we decided that we would go back to win xp on the second pc and give up on vista completely, but just by chance this morning she booted up the vista machine before I could put the win xp cd in... Well, lo and behold windows update ran and both pc's now see the internet no problem.

The settings were fine all along, I was tearing my hair out trying to find some subtle error, but nothing was wrong.

I wish I could explain some kind of resolution for people in the same situation, but really, we did nothing. It just started working.

  metafb 12:41 22 Apr 07

by the way, thanks for all the responses and trying to help :-)

  metafb 19:49 22 Apr 07

Actually found what it was.... PC Guard.

Using windows firewall now and it works fine.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Prehistoric Britain is laid out in these Royal Mail stamp illustrations

Best running headphones | Best sport & fitness headphones: 4 brilliant pairs of wireless…