Problems with Rome-Total War

  belcanto 19:59 27 Mar 05
Locked

Hi there-I brought rome-total war after watching and enjoying "Time Commanders" on the Tv. The thing is though is that it wont play properly, despite getting a patch from the website, updating soundcard/graphics drivers. The problem is this: First of all it installs without asking for the installation code. Next it keeps on crashing, sometimes after I win the tutorial battle, at other times when I am trying to take my first town. Third, on the options screen, the cursor ghosts all over the palce if I move it, making it impossible for me to see the screen after awhile. Can any one help?

My rig is: Amd Atholon XP2800+, 80gb hd, 512 memory, creative Audigy Ls sound card, Nvidia FX5200 128 mb Agp graphics card.

Belcanto

  rmriph 20:26 27 Mar 05

Hi,Have you disabled your antivirus and internet security before starting the game?Try using a search site and typing in Rome,there is one site dealing with the problems they might be able to help.I have a lower spec computer and after some problems it is working OK ,good luck
Bob

  Ivor_Monkey 21:05 27 Mar 05

belcanto, the installation procedure seemed to have gone wrong.

Uninstall and reinstall with anti virus off.

I presume the game is from a reputable supplier. In which case, if it doesn't play properly after your reinstall atempt, take it back. I think you need an installation code.

  rmriph 08:17 28 Mar 05

Hi, found the site that helped me get out of trouble click here
Bob

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…