Problems with RedHat 8 bootloader

  lloydsj 10:48 08 Feb 03

I've installed Red Hat 8 onto my second hard disc (Win 98 is on the first hard disc). Red Hat installed the bootloader, Grub v0.92 and now Red Hat will boot fine, but Windows no longer boots. I get the following error:

Booting Windows 98
Rootnoverify (HD1,0)
chainloader +1

Invalid system disc. Replace the disc and press any key.

I tried changing the rootnoverify so it just said root and this time I got the error:

File system type is EXT2FS, partition type 0x83

Then the chainloader +1 and invalid system disc message again.

I've tried my Windows 98 boot disc and get into DOS and I can access the drives and all my files still seem to be there.

Anyone got any suggestions about how to get Windows to boot correctly, or am I going to need to reinstall Windows (and therefore wipe off grub) ?

Anyone have a similar problem?


  Taran 23:41 09 Feb 03

One of the better articles on GRUB, how it works and why it does things certain ways can be found click here

A quick glance at your configuration above looks like GRUB is seraching for Windows on the wrong disk.

Check out the article and see where you get.



This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Prehistoric Britain is laid out in these Royal Mail stamp illustrations

Best running headphones | Best sport & fitness headphones: 4 brilliant pairs of wireless…