Problems re formats in Office 2K versus Office 97

  Nosmas 10:07 16 Jul 05
Locked

I have recently upgraded my whole system, and have moved from W98 and Office 97 to XP and Office 2000. Now when I open Excel files created under O97 I find that any dates which were originally formatted dd/mm/yy are now dd/mm/yyyy, and because these will not fit in the available column width (they show as '##########') this has to be increased. Apart from creating a 'custom' format of dd/mm/yy and then having to re-format every cell containing a date (a daunting task) does anyone know of a 'quick fix' for this problem?

I have also noticed that when a file is first opened in O2K the 'zoom' setting seems to be different from what I recall it was in O97 - e.g. I am fairly certain that I had 75% set in O97 but this has become 60% in O2K. Apart from being too small for viewing it has the effect of making columns of values appear to be slightly mis-aligned - e.g. 646.93 looks wider than 647.15 because the '9' is wider than the '1'. This effect disappears if the 'zoom' setting is increased sufficiently. Have any other readers experienced this sort of problem? Is there anything that can be done before opening the file in O2K to avoid this?

  VoG II 10:13 16 Jul 05

I don't know about the zoom problem.

For the dates go into Control Panel, Regional and Language Options and change the Short Date format.

  Taff36 10:45 16 Jul 05

I think the zoom problem could be one of two things. On your original system your screen size and resolution was lower and XP/Office 2000 somehow has compensated for it or the default font is different on your current system. Of course the new resolution which is presumably better now means you notice it more.

As you say different fonts take up different "space" for each numeral. Try opening a new worksheet, make row 1 Arial, row 2 Times New Roman and 3 Verdana. Make all the rows point size 12 and type 1234567890 into each Column A cell individually. You`ll see what I mean. As VoG will tell you some fonts are better than others visually if you are comparing larger numbers because a quick glance at a column of figures enequally spaced (Arial) could lead you to believe that one figure is a larger amount because of the space it takes up when the reverse is true.

  Nosmas 12:27 16 Jul 05

Many thanks for your very prompt response. I customised the short date format and it has worked perfectly so once again you are the 'tops' when it comes to resolving Excel problems

  Nosmas 12:30 16 Jul 05

Thank you also for your suggestions. I think the screen resolution is part of the cause. In W98 I had it set to 1024 x 768 but in XP I have it set to 1152 x 864. I tried your ideas with different fonts and found that at too low a 'zoom' setting they all suffer from a degree of 'mis-alignment', but as the zoom is increased that disappears. The default font is Arial 10 and I am fairly certain that I left it at that for most of my worksheets in the O97 version of Excel. However I noticed that when opened in the O2K version it had changed to Times New Roman. I am not 100% sure that this particular file was originally Arial 10 as one gets used to the appearance on screen without noticing such detail as the font in use. However if it has actually changed I suppose it must be put down to Excel trying to compensate for resolution changes.

  Taff36 15:41 16 Jul 05

Yep! My old Office Excel 97 was definately Arial too. In Office XP 2002 the default was different so I had to change the default workbook font to Arial again. (Only because I was used to Arial - note my previous comments because this font does "shrink to Fit" as it were)

Try changing the default font for a new workbook and see if that cures it.

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Why ecommerce hasn't taken off on social media

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…