Problem with wireless router - even when wired!

  evansg 14:17 17 Dec 06
Locked

Hi. I have a perfectly functioning ntl broadband connection and I bought a linksys wireless router yesterday, which is giving me problems.

Initially, it seemed to install correctly and I could see an 'excellent' signal from my new network. But when I tried to connec it told me 'limited or no connectivity'. At this point I could still use the internet if I plugged into the router.

Today however I can't even get wired access through the router - I can only get on the net if I connect the bb modem straight to the computer, AND reset it! I get the same message again, limited or no connectivity.

When I tried to repair the connection it told me something about DNS not assigning an IP address to my computer or something? When I rang ntl they told me to choose DHCP and that an IP should be automatically assigned.

I have only recently switched from Mac to PC and I don't know that much about computers anyway so any help would be greatly appreciated!

PS I have tried resetting everything, and to clarify, the connection works perfectly if I plug straight into the modem (I have also tried a different ethernet cable so it's not the physical connection)

Thanks

  rodriguez 14:28 17 Dec 06

Do you know the model number of the wireless router? If you post it on here I can find out how to enable DHCP on it - however this is normally enabled by default.

  evansg 14:46 17 Dec 06

Yes, it's model WRT54GS

Thanks

  rodriguez 16:07 17 Dec 06

Firstly, click here to open up the router's config page. If it asks for a username and password, by default the username is left blank and the password is admin. If this is different, it should say in the manual. Then go to Setup and the basic setup page will come up. The Internet Connection Type should be set as Automatic - DHCP. When this is done, go to Start, Control Panel and then Network Connections. You should see your network connections and double click the one you are using (Should be called Local Area Connection). Click the Properties button and in the list highlight Internet Protocol (TCP/IP) and click Properties. Then press both Obtain IP and Obtain DNS addresses automatically and press OK and press OK in the other box to exit. Now it should automatically set the IP address of your computer and it should connect.

  evansg 18:41 17 Dec 06

I tried the above rodriguez, but as you assumed, all of those settings were already correct.

Interestingly, I've now discovered that if I reset the modem and plug it into the router, then the router into the laptop (wired), the connection works. But as soon as I try to connect to the wireless network I get the above problem. Then, if I try to connect again, even straight to the modem (without the router), the connection won't work until I reset the cable modem again.

Any other ideas? I will try technical support line but I've never found them much help in the past.

  moh23 18:50 17 Dec 06

have you got the security enabled on the router if you have try it with the security disabled

  postie24 19:07 17 Dec 06

Make sure the dns client is running.Control panel/admin tools/services shortcut.The dns client should be running in there.

  evansg 20:25 17 Dec 06

moh23 - I already tried disabling the security

postie24 - I just checked, and the DNS client is running

I don't get it
:(

  keith-236785 21:51 17 Dec 06

do you get a message about the hardware switch for wireless networking, if so try pressing fn+ F2 on the laptop to turn on the wireless hardware switch.

its a real pain but i found it eventually.

also have to follow the same route of switch on.

modem first, wait for steady lights,
router second, wait a few seconds again,
laptop last, thats the only way to get it to connect wirelessly.

this is on my sister in laws pc which was from pcword.

my own laptop from dell worked without fault.

hope this helps

  keith-236785 21:51 17 Dec 06

do you get a message about the hardware switch for wireless networking, if so try pressing fn+ F2 on the laptop to turn on the wireless hardware switch.

its a real pain but i found it eventually.

also have to follow the same route of switch on.

modem first, wait for steady lights,
router second, wait a few seconds again,
laptop last, thats the only way to get it to connect wirelessly.

this is on my sister in laws pc which was from pcword.

my own laptop from dell worked without fault.

hope this helps

  keith-236785 21:51 17 Dec 06

sorry, a bit trigger happy there.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac