Problem trying to get slave drive to run under DMA

  Shappy 19:29 07 Sep 03
Locked

I've put a 160Mb Maxtor drive in as a slave drive to a Maxtor 40Mb master drive which is still running fine under Ultra DMA mode 5.

Machine is an Athlon XP1800+ processor running at 1.55GHz and 512Mb RAM, so ought to be beefy enough.

Have tried everything I can find on the Maxtor web-site to resolve the problem of the slave drive refusing to budge out of slow PIO transfer and use DMA, including:
1. waited until new slave drive had done more then 10 power-ups - Maxtor say the Write Verify is then switched off
2. have de-installed the Primary IDE Controller and allowed XP to reinstall
3. checked I have Drive 1 set to 'use DMA if available' (as for Drive 0, which is fine)
4. have manually run Maxtor's utility to ensure the Write Verifiy is set off
5. I have an 80-conductor cable - presumably the master drive wouldn't go fast if I hadn't anyway

I'm now really, and logically, stuck having eliminated everything I can think of, and unable to use my new slave drive, as planned, for fast video-editing.

Anyone possibly got any other ideas - I've picked up some vague reference to this being an XP problem ??

  Kryten 19:33 07 Sep 03

Have you tried the motherboard manufactures website to see if there are any updates to the IDE drivers?

  Shappy 19:59 07 Sep 03

No, not yet, so thanks for the prompt, and also for 'instant' response. Likewise, I'm just a little nervous about BIOS updates and the like as I'm not entirely sure where to look and how to implement.

I'll have a hunt for these.

  Kryten 20:10 07 Sep 03

You wont need to update the bios just the drivers to replace Windows IDE Drivers, as they are not always adequate enough to run DMA. But you may have to update the Bios if Updating the IDE drivers does not work.

  Shappy 20:20 07 Sep 03

Thanks again for rapid help. You're right - most of my devices seem to have standard Windows drivers, so I didn't think I'd need to look for updates as I've taken all the XP service packs to date.

Any idea how I find out my IDE Controller manufacturer and product reference id ??

  Kryten 19:45 08 Sep 03

If you go here click here and run the System Resource Analysis. After the tests you will ge given your results. If you click on SYSTEM you will ge given the Name of the system-board. You can then go to the manufacturers website and download the latest drivers for the motherboard.

On PcPitstop you can log on anonymously.

  SEASHANTY 20:05 08 Sep 03

^

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…