Problem setting up file sharing

  oldphil 23:09 13 Jun 06
Locked

i am trying to set up a network with 2 pc and a laptop. I have a Belkin Pre-n wireless modem/router and pre-n cards. They all connect up to the internet OK, but I am having problems with setting up a network.
I have run the network wizard on all of them, but still cant see any of them. In My Network Places/Entire network, microsoft windows network has a padlock on it, if I click on it my network name is shown but it says I havn't got permission to access it
I have tried turning off all the firewalls, but there is no difference. Do I have to change any settings in the router.
This might take a few posts as its the first time i have done this, so thank you for your patience

  mgmcc 08:53 14 Jun 06

<<< In My Network Places/Entire network, microsoft windows network has a padlock on it, >>>

Are you sure that isn't the normal icon of a globe with a mouse superimposed on it? It could be mistaken for a padlock, but I've never seen or heard of the network being 'locked' with a padlock icon.

The claptrap that Windows displays about nobody having permission to do anything is a generic message displayed whenever there is a problem accessing another computer in the network. It is misleading and frequently quite incorrect.

Check that you have set at least one folder as "shared" in each PC by right clicking it and selecting the Sharing & Security option.

If the "remote" PC you are trying to access is running XP Pro, you may need to have a User Account set up with a Username/Password which matches that of the "local" PC you are using. More about this at click here

Any firewall software should be configured correctly to allow access to the local network traffic. Disabling firewalls doesn't always shut down the program's engine which may still be running in the background.

  oldphil 19:51 14 Jun 06

Thanks very much for your advise.
You are right the icon is a mouse (must have had the wrong glasses on)
I have had some success.
I have turned on sharing for my documents on all 3 pcs + enabled sharing of printers on pc no.1, have enabled file sharing as an exception in windows firewalls.
I can now do this
on PC1 I can see and access only PC2
on PC2 cannot see or access PC1 or laptop
on Laptop can see and access PC2 but not PC1
also neither Laptop or P2 can access printers ( normal & 1 usb ) on PC1
I have run the wizard again but no difference
On the laptop in My Network Places there is a sub heading "Local Network" with PC2s files under it
On PC2 in My Network Places there are only the sub headings The Internet & Unspecified
any ideas
Thanks again Phil

  oldphil 20:03 14 Jun 06

something I missed out
PC2 shows icons for PC1 in microsoft windows/network/my home network but cant access it

  oldphil 20:07 14 Jun 06

They are all running XP Home

  mgmcc 21:04 14 Jun 06

1) See if each computer can successfully 'ping' the other two.

2) Try disabling the Windows firewall in all three computers (the router's hardware firewall will protect you from internet-based attacks).

3) If a particular computer isn't "seen" in My Network Places, try entering its path directly into the address bar, using either its name or its IP address, for example"

\\computer_name

\\computer_name\shared_folder

\\192.168.2.2 (or whatever address)

4) If you still have problems AND ARE COMFORTABLE EDITING THE REGISTRY, check this out in any PC that is denying access.

Navigate to:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\ Lsa

look for a DWORD "restrictanonymous" and see what the value is. If it is anything other than 0 (zero), right click the DWORD, select MODIFY and change the decimal value to 0 (zero).

A word of warning, there is a DWORD "restictanonymoussam" just below the one you want - DO NOT change this.

Close regedit and reboot the computer.

  oldphil 10:19 15 Jun 06

all firewalls disabled. Entering IPs in the address bar none of them can seem to be found.
The registry entries are set to 0
Pinging gives the following results
PC1 to PC2 & laptop =OK
L/T to PC1=X, to PC2=OK
PC2 to PC1=X, to L/T=OK
I don't know if this has any bearing, but when I turned off the firewalls all the pcs came up with the warning icon that there was no firewall, except PC1
Thanks Phil

  mgmcc 16:55 15 Jun 06

Despite your having turned off the firewalls, there does *appear* still to be a firewall issue with PC1. If they all have internet access via the router, then they are networked but the inability to 'ping' PC1 suggests firewall blocking.

Something which might help to get them all talking is to use "IPX/SPX/NetBIOS Compatible Transport Protocol". This doesn't need configuring with IP addresses and so on like TCP/IP and isn't affected by firewalls. However, for internet access, TCP/IP is still required.

To install "IPX/SPX/NetBIOS Compatible Transport Protocol" in Windows XP, go into the Network Connections folder, right click the Local Area Connection and select Properties. In the General tab, click the Install button. In the next box, highlight Protocol and click Add. Select "NWLink IPX/SPX/NetBIOS Compatible Transport Protocol" and click OK.

  oldphil 10:55 16 Jun 06

Still the same result i'm afraid.
I can access files one way on each pc which will let me move files around, I think we have spend enough time on this. With PC1 when I first disabled windows firewall it said that Mcafee was still protecting it, but that was uninstalled ages ago, so that might be part of the conflict, but still doesn't explain why pc2 can't access the laptop, which had a clean install recently. I will have to go through the registry sometime and remove all references to Mcafee.
Thanks you very much for your help but I am getting moaned at by "her indoor" about mucking about with the pc she's using.
I could always use messenger to copy files
Thanks again
Phil

  Switcher 15:12 12 Aug 06

solved my Peoblem after hours Thanks MGMCC

This thread is now locked and can not be replied to.

New Google phones UK release date | Pixel XL price, new features, specifications: Pixel X and…

1995-2015: How technology has changed the world in 20 years

iOS 10 troubleshooting tips: Simple fixes for the most common iOS 10 problems, from network…