Problem saving to an USB drive

  Mr. Chips 10:31 07 Dec 09
Locked

Out of the blue, I am now unable to save to a 2gig USB drive which has plenty of space on it.

I get the error "The directory or file cannot be created"

I have tried the drive in another USB slot.
I can move files around inside the drive.
I did a check disk.
... all with no problems.
Another USB drive will work.

I have checked 'properties' and cannot find that it has become ' read only' (although I have not been able to find a dialogue box with that option).
I have 'shared' the drive.
I am using XP with all patches up-to-date.

Can anyone make a suggestion how to change a setting to enable files to be saved.

  ArrGee 10:51 07 Dec 09

Have you tried to perform a full format on the drive?

  Mr. Chips 13:07 07 Dec 09

ArrGee .

No I haven't tried a format.
I hadn't thought that would be necessary ... hoping that whatever 'switch' had been set could be unset.

  chub_tor 13:23 07 Dec 09

It does sound as if your stick has become read only, formatting is a good idea and usually solves the problem if not click here

  Mr. Chips 13:45 07 Dec 09

OK ... I will try to copy the existing stuff from the drive ... format it ... and then see if it resets itself to read/write.

thanks for your time, both of you ... I will let you know how it gets on.

  Mr. Chips 13:55 07 Dec 09

Well .... it has been formatted and seems to be accepting the files back onto it.

Thank you for spending the time getting me through this problem.

I would not have thought of a re-format ... I was looking for the reason why the thing went read only.

regards, and have a great Xmas and New Year

This thread is now locked and can not be replied to.

Qualcomm Snapdragon 835 benchmarks: Antutu, Geekbench 4, GFXBench and PCMark results

1995-2015: How technology has changed the world in 20 years

This stop-frame animation tells a moving story of domestic violence for Refuge

New iPad 2017 preview: Apple's affordable but underspecced new iPad may appeal to the education…